summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/unittest++')
-rw-r--r--dev-libs/unittest++/files/unittest++-2.0.0-fix-tests-with-clang.patch27
-rw-r--r--dev-libs/unittest++/unittest++-2.0.0.ebuild6
2 files changed, 31 insertions, 2 deletions
diff --git a/dev-libs/unittest++/files/unittest++-2.0.0-fix-tests-with-clang.patch b/dev-libs/unittest++/files/unittest++-2.0.0-fix-tests-with-clang.patch
new file mode 100644
index 000000000000..201ff10de5a3
--- /dev/null
+++ b/dev-libs/unittest++/files/unittest++-2.0.0-fix-tests-with-clang.patch
@@ -0,0 +1,27 @@
+commit 2423fcac7668aa9c331a2dcf024c3ca06742942d
+Author: Dan Huantes <daniel.f.huantes@saic.com>
+Date: Thu Aug 15 08:26:41 2019 -0500
+
+ CrasingTestsAreReportedAsFailures no longer core dumps on Clang Release
+
+ Found that Crashing tests at some point in Clang
+ history were actually caught but testing on
+ Clang 6.0 and Clang 7.0 this is not the case.
+ So added Clang to the list of compilers that
+ don't run this tests. Noted that several
+ other Pull Requests were failing for the same
+ reason.
+
+diff --git a/tests/TestTest.cpp b/tests/TestTest.cpp
+index 5a4e1ca..0db0650 100644
+--- a/tests/TestTest.cpp
++++ b/tests/TestTest.cpp
+@@ -72,7 +72,7 @@ namespace {
+ CHECK_EQUAL(1, results.GetFailureCount());
+ }
+
+-#if !defined(UNITTEST_MINGW) && !defined(UNITTEST_WIN32)
++#if !defined(UNITTEST_MINGW) && !defined(UNITTEST_WIN32) && !defined(__clang__)
+ // Skip this test in debug because some debuggers don't like it.
+ #if defined(NDEBUG)
+ TEST(CrashingTestsAreReportedAsFailures)
diff --git a/dev-libs/unittest++/unittest++-2.0.0.ebuild b/dev-libs/unittest++/unittest++-2.0.0.ebuild
index af6ca1612495..88339de12284 100644
--- a/dev-libs/unittest++/unittest++-2.0.0.ebuild
+++ b/dev-libs/unittest++/unittest++-2.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -11,6 +11,7 @@ MY_P="${MY_PN}-${PV}"
DESCRIPTION="A lightweight unit testing framework for C++"
HOMEPAGE="https://unittest-cpp.github.io/"
SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="MIT"
SLOT="0"
@@ -18,7 +19,8 @@ KEYWORDS="amd64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
-S="${WORKDIR}/${MY_P}"
+# https://github.com/unittest-cpp/unittest-cpp/commit/2423fcac7668aa9c331a2dcf024c3ca06742942d
+PATCHES=( "${FILESDIR}/${P}-fix-tests-with-clang.patch" )
src_prepare() {
cmake-utils_src_prepare