summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/xerces-c/xerces-c-3.2.3-r2.ebuild')
-rw-r--r--dev-libs/xerces-c/xerces-c-3.2.3-r2.ebuild117
1 files changed, 0 insertions, 117 deletions
diff --git a/dev-libs/xerces-c/xerces-c-3.2.3-r2.ebuild b/dev-libs/xerces-c/xerces-c-3.2.3-r2.ebuild
deleted file mode 100644
index c72408418f20..000000000000
--- a/dev-libs/xerces-c/xerces-c-3.2.3-r2.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake prefix
-
-DESCRIPTION="A validating XML parser written in a portable subset of C++"
-HOMEPAGE="https://xerces.apache.org/xerces-c/"
-
-if [[ ${PV} == *9999 ]] ; then
- ESVN_REPO_URI="https://svn.apache.org/repos/asf/xerces/c/trunk"
- inherit subversion
-else
- SRC_URI="mirror://apache/xerces/c/3/sources/${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-fi
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="cpu_flags_x86_sse2 curl doc examples iconv icu static-libs test threads"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- curl? ( net-misc/curl )
- icu? ( dev-libs/icu:0= )
- virtual/libiconv"
-DEPEND="${RDEPEND}"
-BDEPEND="
- doc? ( app-doc/doxygen )
- test? ( dev-lang/perl )"
-
-DOCS=( CREDITS KEYS NOTICE README )
-
-PATCHES=( "${FILESDIR}"/${PN}-3.2.2-fix-XERCESC-2163.patch )
-
-pkg_setup() {
- export ICUROOT="${EPREFIX}/usr"
-
- if use iconv && use icu; then
- ewarn "This package can use iconv or icu for loading messages"
- ewarn "and transcoding, but not both. ICU takes precedence."
- fi
-}
-
-src_configure() {
- # 'cfurl' is only available on OSX and 'socket' isn't supposed to work.
- # But the docs aren't clear about it, so we would need some testing...
- local netaccessor
- if use curl; then
- netaccessor="curl"
- elif use elibc_Darwin; then
- netaccessor="cfurl"
- else
- netaccessor="socket"
- fi
-
- local msgloader
- if use icu; then
- msgloader="icu"
- elif use iconv; then
- msgloader="iconv"
- else
- msgloader="inmemory"
- fi
-
- local transcoder
- if use icu; then
- transcoder="icu"
- elif use elibc_Darwin; then
- transcoder="macosunicodeconverter"
- else
- transcoder="gnuiconv"
- fi
- # for interix maybe: transcoder="windows"
-
- local mycmakeargs=(
- -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${PF}"
- -Dnetwork-accessor="${netaccessor}"
- -Dmessage-loader="${msgloader}"
- -Dtranscoder="${transcoder}"
- -Dthreads:BOOL="$(usex threads)"
- -Dsse2:BOOL="$(usex cpu_flags_x86_sse2)"
- )
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
-
- use doc && cmake_build doc-style createapidocs doc-xml
-}
-
-src_install() {
- cmake_src_install
-
- # package provides .pc files
- find "${D}" -name '*.la' -delete || die
-
- if use examples; then
- # clean out object files, executables, Makefiles
- # and the like before installing examples
- find samples/ \( -type f -executable -o -iname 'runConfigure' -o -iname '*.o' \
- -o -iname '.libs' -o -iname 'Makefile*' \) -exec rm -rf '{}' + || die
- docinto examples
- dodoc -r samples/.
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- # To make sure an appropriate NLS msg file is around when using
- # the iconv msgloader ICU has the messages compiled in.
- if use iconv && ! use icu; then
- doenvd "$(prefixify_ro "${FILESDIR}/50xerces-c")"
- fi
-}