summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/mxml/Manifest2
-rw-r--r--dev-libs/mxml/files/respect-users-flags.patch30
-rw-r--r--dev-libs/mxml/mxml-2.10.ebuild57
-rw-r--r--dev-libs/mxml/mxml-2.11.ebuild52
4 files changed, 0 insertions, 141 deletions
diff --git a/dev-libs/mxml/Manifest b/dev-libs/mxml/Manifest
index 416b138c3931..85659fdfe216 100644
--- a/dev-libs/mxml/Manifest
+++ b/dev-libs/mxml/Manifest
@@ -1,3 +1 @@
-DIST mxml-2.10.tar.gz 265398 BLAKE2B eb3edec5615d727dec9285e2b74f4c877e8332be8f8183483e85a91d92ca1f48e5fc6d06afa3650c133c9762998abfdc8e846a9961ce55251d0c5bbcba0a970f SHA512 c3838611979c4228df476166e4e987fc1ff8f9b8bd30139066b475dcd99e25be81ecc5171235bc80b1c2291c9d78c9ceae9a1dfc928272a983740d6a67372f5c
-DIST mxml-2.11.tar.gz 9164003 BLAKE2B d124b7d779e7ea9609a91b823fe7f6b45ab4049e79eb72729ca2ffec93a83479d5fed1ef21efc76881a11de58be71b1f3de79fc3e4f07c26f35d3f68e25c017b SHA512 046421f91eea16f0ca99fbf611891c367ea9c3c54d04080d08acf108d7749ad9bbf2f4b3ef234a5130f00f77618196e2c5a245f32230daf645c1f775e961d378
DIST mxml-2.12.tar.gz 9112072 BLAKE2B 29e63abdd567c76209ca41adf608bd752863cdb2911d5bda482a2c6ac50ccdae2179941a3899d7e58480bab8903fee8a6c431619072d2861acd01f18d0eeb9e5 SHA512 49233a0087f3ef73a01ef71bb79511af36bb72027e3d9f6df919385e9ff0b03a489a3ccc590941bc4af1f558f82b2ed9bf8ff641863300a7791ce6dddfd56e77
diff --git a/dev-libs/mxml/files/respect-users-flags.patch b/dev-libs/mxml/files/respect-users-flags.patch
deleted file mode 100644
index 90e49cf2198e..000000000000
--- a/dev-libs/mxml/files/respect-users-flags.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/configure.ac 2017-10-28 18:23:11.000000000 +0200
-+++ b/configure.ac 2018-07-13 23:29:39.710622168 +0200
-@@ -255,7 +255,7 @@
- CFLAGS="-Wall -D_GNU_SOURCE $CFLAGS"
-
- if test "x$OPTIM" = x; then
-- OPTIM="-Os -g"
-+ OPTIM=""
- fi
-
- if test "x$use_ansi" = xyes; then
---- a/Makefile.in 2017-10-28 18:23:11.000000000 +0200
-+++ b/Makefile.in 2018-07-13 23:27:51.101622582 +0200
-@@ -67,7 +67,6 @@
- # Rules...
- #
-
--.SILENT:
- .SUFFIXES: .c .man .o
- .c.o:
- echo Compiling $<
-@@ -271,7 +270,7 @@
-
- libmxml.so.1.6: $(LIBOBJS)
- echo Creating $@...
-- $(DSO) $(DSOFLAGS) -o libmxml.so.1.6 $(LIBOBJS)
-+ $(DSO) $(DSOFLAGS) $(LDFLAGS) -o libmxml.so.1.6 $(LIBOBJS)
- $(RM) libmxml.so libmxml.so.1
- $(LN) libmxml.so.1.6 libmxml.so
- $(LN) libmxml.so.1.6 libmxml.so.1
diff --git a/dev-libs/mxml/mxml-2.10.ebuild b/dev-libs/mxml/mxml-2.10.ebuild
deleted file mode 100644
index 2406db40c704..000000000000
--- a/dev-libs/mxml/mxml-2.10.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools
-
-DESCRIPTION="Small XML parsing library to read XML and XML-like data files"
-HOMEPAGE="http://www.minixml.org/"
-SRC_URI="http://www.msweet.org/files/project3/${P}.tar.gz"
-
-LICENSE="Mini-XML"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ppc ~ppc64 ~sparc x86"
-IUSE="threads static-libs"
-
-DEPEND="virtual/pkgconfig"
-RDEPEND=""
-
-src_prepare() {
- default
- sed -e "s:755 -s:755:" \
- -e "/^TARGETS/s: testmxml::" \
- -e 's:$(DSO) $(DSOFLAGS) -o libmxml.so.1.5 $(LIBOBJS):$(DSO) $(DSOFLAGS) $(LDFLAGS) -o libmxml.so.1.5 $(LIBOBJS):' \
- -i Makefile.in || die
- sed -i -e 's:OPTIM="-Os -g":OPTIM="":' configure.ac || die
- rm configure || die
- #eautoreconf
- eautoconf
-}
-
-src_configure() {
- econf \
- --enable-shared \
- --libdir="/usr/$(get_libdir)" \
- --with-docdir="/usr/share/doc/${PF}/html" \
- $(use_enable threads)
-}
-
-src_compile() {
- emake libmxml.so.1.5 mxmldoc doc/mxml.man
-}
-
-src_install() {
- emake DSTROOT="${ED}" install
-
- if ! use static-libs; then
- rm "${ED}"/usr/$(get_libdir)/libmxml.a || die
- fi
-
- dodoc ANNOUNCEMENT CHANGES README
- rm "${ED}/usr/share/doc/${PF}/html/"{CHANGES,COPYING,README} || die
-}
-
-src_test() {
- emake testmxml
-}
diff --git a/dev-libs/mxml/mxml-2.11.ebuild b/dev-libs/mxml/mxml-2.11.ebuild
deleted file mode 100644
index 6a58f55a52bd..000000000000
--- a/dev-libs/mxml/mxml-2.11.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools
-
-DESCRIPTION="A small XML parsing library that you can use to read XML data files or strings"
-HOMEPAGE="https://github.com/michaelrsweet/mxml
- https://www.msweet.org/mxml/"
-SRC_URI="https://github.com/michaelrsweet/mxml/releases/download/v${PV}/${P}.tar.gz"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-LICENSE="Mini-XML"
-SLOT="0"
-IUSE="static-libs test threads"
-
-DEPEND="virtual/pkgconfig"
-
-S="${WORKDIR}"
-
-PATCHES=( "${FILESDIR}"/respect-users-flags.patch )
-
-src_prepare() {
- default
-
- eautoconf
-}
-
-src_configure() {
- local myeconfopts=(
- $(use_enable threads)
- )
-
- econf "${myeconfopts[@]}"
-}
-
-src_compile() {
- emake libmxml.so.1.6 doc/mxml.man mxmldoc
-}
-
-src_test() {
- emake testmxml
-}
-
-src_install() {
- emake DSTROOT="${ED}" install
-
- if ! use static-libs; then
- rm "${ED%/}"/usr/$(get_libdir)/libmxml.a || die
- fi
-}