summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/xxhash/files/xxhash-0.6.5-compile-xxhash.o-once.patch28
-rw-r--r--dev-libs/xxhash/files/xxhash-0.6.5-do-not-compile-xxhash.o-twice.patch11
-rw-r--r--dev-libs/xxhash/xxhash-0.6.5.ebuild2
3 files changed, 29 insertions, 12 deletions
diff --git a/dev-libs/xxhash/files/xxhash-0.6.5-compile-xxhash.o-once.patch b/dev-libs/xxhash/files/xxhash-0.6.5-compile-xxhash.o-once.patch
new file mode 100644
index 000000000000..2eb7f8c22a8b
--- /dev/null
+++ b/dev-libs/xxhash/files/xxhash-0.6.5-compile-xxhash.o-once.patch
@@ -0,0 +1,28 @@
+--- a/Makefile
++++ b/Makefile
+@@ -82,7 +82,7 @@
+ all: lib xxhsum xxhsum_inlinedXXH
+
+ xxhsum32: CFLAGS += -m32
+-xxhsum xxhsum32: xxhash.c xxhsum.c
++xxhsum xxhsum32: xxhash.o xxhsum.c
+ $(CC) $(FLAGS) $^ -o $@$(EXT)
+
+ .PHONY: xxhsum_and_links
+@@ -105,12 +105,12 @@
+ ifeq (,$(filter Windows%,$(OS)))
+ $(LIBXXH): LDFLAGS += -fPIC
+ endif
+-$(LIBXXH): xxhash.c
++$(LIBXXH): xxhash.o
+ @echo compiling dynamic library $(LIBVER)
+- @$(CC) $(FLAGS) $^ $(LDFLAGS) $(SONAME_FLAGS) -o $@
++ $(CC) $(FLAGS) $^ $(LDFLAGS) $(SONAME_FLAGS) -o $@
+ @echo creating versioned links
+- @ln -sf $@ libxxhash.$(SHARED_EXT_MAJOR)
+- @ln -sf $@ libxxhash.$(SHARED_EXT)
++ ln -sf $@ libxxhash.$(SHARED_EXT_MAJOR)
++ ln -sf $@ libxxhash.$(SHARED_EXT)
+
+ libxxhash : $(LIBXXH)
+
diff --git a/dev-libs/xxhash/files/xxhash-0.6.5-do-not-compile-xxhash.o-twice.patch b/dev-libs/xxhash/files/xxhash-0.6.5-do-not-compile-xxhash.o-twice.patch
deleted file mode 100644
index dcbc8c32dec9..000000000000
--- a/dev-libs/xxhash/files/xxhash-0.6.5-do-not-compile-xxhash.o-twice.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -82,7 +82,7 @@
- all: lib xxhsum xxhsum_inlinedXXH
-
- xxhsum32: CFLAGS += -m32
--xxhsum xxhsum32: xxhash.c xxhsum.c
-+xxhsum xxhsum32: xxhash.o xxhsum.c
- $(CC) $(FLAGS) $^ -o $@$(EXT)
-
- .PHONY: xxhsum_and_links
diff --git a/dev-libs/xxhash/xxhash-0.6.5.ebuild b/dev-libs/xxhash/xxhash-0.6.5.ebuild
index f8633569a91b..503fce793804 100644
--- a/dev-libs/xxhash/xxhash-0.6.5.ebuild
+++ b/dev-libs/xxhash/xxhash-0.6.5.ebuild
@@ -17,7 +17,7 @@ DEPEND=""
S="${WORKDIR}/xxHash-${PV}"
PATCHES=(
- "${FILESDIR}"/${PN}-0.6.5-do-not-compile-xxhash.o-twice.patch
+ "${FILESDIR}"/${PN}-0.6.5-compile-xxhash.o-once.patch
)
src_configure() {