summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/pugixml/Manifest1
-rw-r--r--dev-libs/pugixml/pugixml-1.9.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-libs/pugixml/Manifest b/dev-libs/pugixml/Manifest
index c0143266512f..14f9b1635e97 100644
--- a/dev-libs/pugixml/Manifest
+++ b/dev-libs/pugixml/Manifest
@@ -1 +1,2 @@
DIST pugixml-1.8.tar.gz 357806 BLAKE2B 7f7b9c0a1e51186b6511c53dfd11a3fabbc28343e87fcb98c0480a6b8216bb6dbbfc7bc6bfa7b06b649061910b542747a60c7b04d76b5683f4d823da5f9d4dcc SHA512 f59d83e6685949ab392fb08a60b9153f709697e7c1f93989c3d07ac1817b381fa13b2bea23914de803c4db090e3f503d943db0baf53597f7f8c7d734e8028f42
+DIST pugixml-1.9.tar.gz 377369 BLAKE2B 39b5b0d63a20e9c15c5634e56f82207aed63843d252900db94dbf06d100d03916a16523ccb9de433cc94ded4a9e9d1dc11f47bfd6fd75e348a9a2af31c305db6 SHA512 853a9d985aae537391c6524d5413ef4de237d99d96cc58ea7fe7152f786df1e408cdacd2e4387697e23c3e67cdc1d42b29de554501309eae16d86edd0e24785f
diff --git a/dev-libs/pugixml/pugixml-1.9.ebuild b/dev-libs/pugixml/pugixml-1.9.ebuild
new file mode 100644
index 000000000000..38a691d1f58f
--- /dev/null
+++ b/dev-libs/pugixml/pugixml-1.9.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+CMAKE_MAKEFILE_GENERATOR=emake
+
+inherit cmake-utils
+
+DESCRIPTION="Light-weight, simple, and fast XML parser for C++ with XPath support"
+HOMEPAGE="https://pugixml.org/ https://github.com/zeux/pugixml/"
+SRC_URI="https://github.com/zeux/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_SHARED_LIBS=ON )
+ cmake-utils_src_configure
+}