summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/rocr-runtime/Manifest1
-rw-r--r--dev-libs/rocr-runtime/files/rocr-runtime-4.5.2-cmake-install-paths.patch40
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-4.5.2.ebuild45
3 files changed, 86 insertions, 0 deletions
diff --git a/dev-libs/rocr-runtime/Manifest b/dev-libs/rocr-runtime/Manifest
index 36efcbb03efe..abe87a169710 100644
--- a/dev-libs/rocr-runtime/Manifest
+++ b/dev-libs/rocr-runtime/Manifest
@@ -5,3 +5,4 @@ DIST rocr-runtime-4.0.0.tar.gz 691835 BLAKE2B 328f7ea54767294036f435894d63354694
DIST rocr-runtime-4.1.0.tar.gz 698452 BLAKE2B fb1ca1219d2c59db4d8bff414f40eaf6e7cec899a70ed930ce3dc6e2906a173db4823ac4c445fc57cc297a932f83b140747e35ee3d77fa0ed11cec97718fdc47 SHA512 d2162f431adf0b8f8ae5bbfe43ed389d4d94db5897fc8d1b4eb9b152a74f605fa2cf5d80175e6f9cda45e39803ededef6151aa9bdea99f38a16ca2dea29588d9
DIST rocr-runtime-4.2.0.tar.gz 701445 BLAKE2B 901c256bae823861813a7afdbd3e9f80b6f86cf2c7002815e04c762cef241a9f32274093067c97578e05fdf5c4e699287b7835d00917cb4997302c455e5d593a SHA512 44a798efd0121c7107f3f5df868eb83d0ff9aad1e11c01105d5852bef159c019db6d2aeebe02e8e187dc45a2542d72f145fb5390b27abf64e0b427e192772d6c
DIST rocr-runtime-4.3.0.tar.gz 709075 BLAKE2B 6856681bd3d56827e517f76838886f793f4d709562c2c7c4f480ef5786c5a5fac25654032b80d565ab5da241f76329d39ab3189daa4806b8cf1564d9f08a837d SHA512 749a8f84a302f7ed518f87688f68cc2a094eea2d104cddc25b3e5d98ddf6e534285750828ca654976054bbf986a61735e17ad211505557671627e44f6831dc0c
+DIST rocr-runtime-4.5.2.tar.gz 717648 BLAKE2B f3acf32943b73b65f1272317bbd8928d1a05e9985ec6242f0480cfdb988052caef198900643fc42288af6acd5fbe2052f063b022219b2ef0d3fb843032de6c92 SHA512 69d7a3f7960ffca339d706a9356e0994851761a135e1b7e7b9b451bcff5782c119b99756432546e7f066f8b60b8717557340cf382f8a9beae6336d23d90ecae4
diff --git a/dev-libs/rocr-runtime/files/rocr-runtime-4.5.2-cmake-install-paths.patch b/dev-libs/rocr-runtime/files/rocr-runtime-4.5.2-cmake-install-paths.patch
new file mode 100644
index 000000000000..063fafe336f7
--- /dev/null
+++ b/dev-libs/rocr-runtime/files/rocr-runtime-4.5.2-cmake-install-paths.patch
@@ -0,0 +1,40 @@
+--- a/CMakeLists.txt 2021-12-10 22:55:24.000000000 +0100
++++ b/CMakeLists.txt 2021-12-15 15:33:43.545084656 +0100
+@@ -286,35 +286,17 @@
+ install ( TARGETS ${CORE_RUNTIME_NAME} EXPORT ${CORE_RUNTIME_NAME}Targets )
+ endif()
+
+-## Create symlinks for legacy packaging and install
+-add_custom_target ( hsa_include_link ALL WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${CMAKE_COMMAND} -E create_symlink ../../include/hsa hsa_include_link )
+-if ( ${BUILD_SHARED_LIBS} )
+- add_custom_target ( hsa_lib_link ALL WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${CMAKE_COMMAND} -E create_symlink ../../lib/${CORE_RUNTIME_LIBRARY}.so ${CORE_RUNTIME_LIBRARY}-link.so )
+- add_custom_target ( hsa_lib_link2 ALL WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${CMAKE_COMMAND} -E create_symlink ../../lib/${CORE_RUNTIME_LIBRARY}.so.${VERSION_MAJOR} ${CORE_RUNTIME_LIBRARY}-link.so.${VERSION_MAJOR} )
+-endif()
+-
+ ## Set install information
+ # Installs binaries and exports the library usage data to ${HSAKMT_TARGET}Targets
+ # TODO: Fix me for flat directory layout. Should be ${CMAKE_INSTALL_LIBDIR}
+-install ( TARGETS ${CORE_RUNTIME_TARGET} EXPORT ${CORE_RUNTIME_NAME}Targets
+- ARCHIVE DESTINATION lib COMPONENT binary
+- LIBRARY DESTINATION lib COMPONENT binary )
++install ( TARGETS ${CORE_RUNTIME_TARGET} EXPORT ${CORE_RUNTIME_NAME}Targets LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR} )
+
+ # Install license
+ #install ( FILES ${CMAKE_CURRENT_SOURCE_DIR}/LICENSE.md DESTINATION ${CMAKE_INSTALL_DOCDIR} COMPONENT binary )
+
+ # Install public headers
+ # TODO: Fix me for flat directory layout. Should be ${CMAKE_INSTALL_INCLUDEDIR}
+-install ( DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/inc/ DESTINATION include/hsa COMPONENT dev )
+-
+-# Legacy symlink - not packaged (CPack is bugged until ~3.18, see https://gitlab.kitware.com/cmake/cmake/-/merge_requests/4637)
+-install ( FILES ${CMAKE_CURRENT_BINARY_DIR}/hsa_include_link DESTINATION hsa/include PERMISSIONS OWNER_WRITE OWNER_READ RENAME hsa )
+-
+-# Legacy symlinks.
+-if ( ${BUILD_SHARED_LIBS} )
+- install ( FILES ${CMAKE_CURRENT_BINARY_DIR}/${CORE_RUNTIME_LIBRARY}-link.so DESTINATION hsa/lib PERMISSIONS OWNER_WRITE OWNER_READ RENAME ${CORE_RUNTIME_LIBRARY}.so COMPONENT binary)
+- install ( FILES ${CMAKE_CURRENT_BINARY_DIR}/${CORE_RUNTIME_LIBRARY}-link.so.${VERSION_MAJOR} DESTINATION hsa/lib PERMISSIONS OWNER_WRITE OWNER_READ RENAME ${CORE_RUNTIME_LIBRARY}.so.${VERSION_MAJOR} COMPONENT binary)
+-endif ()
++install ( DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/inc/ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/hsa )
+
+ ## Configure and install package config file
+ # Record our usage data for clients find_package calls.
diff --git a/dev-libs/rocr-runtime/rocr-runtime-4.5.2.ebuild b/dev-libs/rocr-runtime/rocr-runtime-4.5.2.ebuild
new file mode 100644
index 000000000000..d5c28fbc1b76
--- /dev/null
+++ b/dev-libs/rocr-runtime/rocr-runtime-4.5.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCR-Runtime/"
+ inherit git-r3
+ S="${WORKDIR}/${P}/src"
+else
+ SRC_URI="https://github.com/RadeonOpenCompute/ROCR-Runtime/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/ROCR-Runtime-rocm-${PV}/src"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Radeon Open Compute Runtime"
+HOMEPAGE="https://github.com/RadeonOpenCompute/ROCR-Runtime"
+PATCHES=(
+ "${FILESDIR}/${PN}-4.5.2-cmake-install-paths.patch"
+)
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+
+COMMON_DEPEND="dev-libs/elfutils"
+RDEPEND="${COMMON_DEPEND}"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/roct-thunk-interface-${PV}
+ >=dev-libs/rocm-device-libs-${PV}"
+BDEPEND="app-editors/vim-core"
+ # vim-core is needed for "xxd"
+
+CMAKE_BUILD_TYPE=Release
+
+src_prepare() {
+ # ... otherwise system llvm/clang is used ...
+ sed -e "s:find_package(Clang REQUIRED HINTS \${CMAKE_INSTALL_PREFIX}/llvm \${CMAKE_PREFIX_PATH}/llvm PATHS /opt/rocm/llvm ):find_package(Clang REQUIRED HINTS ${EPREFIX}/usr/lib/llvm/roc ):" -i image/blit_src/CMakeLists.txt || die
+
+ # Gentoo installs "*.bc" to "/usr/lib" instead of a "[path]/bitcode" directory ...
+ sed -e "s:/opt/rocm/amdgcn/bitcode:${EPREFIX}/usr/lib/amdgcn/bitcode:" -i image/blit_src/CMakeLists.txt || die
+
+ cmake_src_prepare
+}