summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libressl/Manifest3
-rw-r--r--dev-libs/libressl/libressl-2.2.9.ebuild47
-rw-r--r--dev-libs/libressl/libressl-2.3.6.ebuild51
-rw-r--r--dev-libs/libressl/libressl-2.4.1.ebuild51
4 files changed, 152 insertions, 0 deletions
diff --git a/dev-libs/libressl/Manifest b/dev-libs/libressl/Manifest
index d1bb1845c10d..f5ac30e6f83b 100644
--- a/dev-libs/libressl/Manifest
+++ b/dev-libs/libressl/Manifest
@@ -1,3 +1,6 @@
DIST libressl-2.2.8.tar.gz 2958840 SHA256 d1051477dbc5dc36f148b53aa959c3e2a0aaa5944eb04c89dd549254825fbb0b SHA512 3fd5b9c967e6310f9ce53220160e76f7453462af48c5771aa05386232682a5b48e9d26fa0bb176246292bef42a0727b078293729312a821bcae4458c21eab115 WHIRLPOOL 36c60731236695e916b363f792448bdf90cd67214fe6177c157c77726d7327bf50d23c18255c6ddff3ff60f3f96996203cb7c1bf007c61cb146f23b496c44920
+DIST libressl-2.2.9.tar.gz 2959045 SHA256 710ff377ea83637239d5010f4d261f5f91c7fdce91a38974149acd03e45c4c44 SHA512 904519f5547d00ac959c9824fbc7aa22b50492b3932bc195ad59de1d16ebb02394feb9ac95890aab96d99de4820fb3276b660cb7a329054a2954b527a523f6ff WHIRLPOOL b95d480bc968a2b32c95959f4de9ddd1c9f439a349e8d37633ea840a7688a8f6189bd15e2efa982ac0dc7b63a47d488dffdf4c09d480dbbe247e4b48a6eac643
DIST libressl-2.3.5.tar.gz 3013316 SHA256 f425275ce7debcc7282c9dcb46bd6eebbaf41ac60136e2fd32d8fd60be8b753b SHA512 b73271ee05ba1bdffbfde02f17a33acf38738a4dfbe69be1bdd8f13a1f03a5fdab4c62a5f62f94c4128ad0d7ad1e6796e554c772d9f0563c61b7da75a8bb1e23 WHIRLPOOL 89dfbeb15a156d5ab6765591b6439ef90d8bfcfc1a3ebf91a2c44e15ed12f2cfd6df6cbe352dc8c5be749b8b7f562ebe06990c99f4a2eb99406738ea5a3b9dd7
+DIST libressl-2.3.6.tar.gz 3013459 SHA256 358a4779e6813bd06f07db0cf0f0fe531401ed0c6ed958973d404416c3d537fa SHA512 d170fb6a457d3ad1861522f47ce27754dc13740575ef1ea397748b18709c3b17e3793a790d68791e3dc421a3e33de0d0ad023ceb8de132b2351f4ce00c8c67e9 WHIRLPOOL efa437081cadecabd4f498a9f672d91d512791448452498c2c5019ea14915d05dd9982dae745e8ed80e16ca714cb8175d154738e2b7c0d65d5d75c1fd877ea2b
DIST libressl-2.4.0.tar.gz 3024184 SHA256 7e6000cfb9438fbfc7fe7fe0572af587e2f2a36bbdb95408e9874758d0c3382e SHA512 147f6bc3cb17d7769e6cc7d947d66bcfa6904a1669eba791f3805c00db3349732adcc1f9e7921d9a8112b0a395b07a426ae1ed0c95580ebea4d94c723a8f133f WHIRLPOOL d0d2fc4454551333d6f90e9b17eac33eacab643a6e270f3a4dac66c115a2c8ffeba948ce5299710e19b83b276aae324bf78dfd7d4150eb35ddbb8c76efcbe681
+DIST libressl-2.4.1.tar.gz 3024529 SHA256 121922b13169cd47a85e3e77f0bc129f8d04247193b42491cb1fab9074e80477 SHA512 61db009bf13e409a822e8438cf6dee4ac3e7d763e548d4afa9bf493c0a24aad760438793eb66d3b9a6e6b3f05a61f6dd26ca4a3368587fe6b8214d5f4a814560 WHIRLPOOL 46defeab207485808c8581aa86b00d556c1226948dc597ae21daee9e06b67275a6fa0a75926af6402839014324dde742620aa7d8ab7436e94a9f97db109cdd05
diff --git a/dev-libs/libressl/libressl-2.2.9.ebuild b/dev-libs/libressl/libressl-2.2.9.ebuild
new file mode 100644
index 000000000000..1dcdc69e6f00
--- /dev/null
+++ b/dev-libs/libressl/libressl-2.2.9.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
+HOMEPAGE="http://www.libressl.org/"
+SRC_URI="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+
+LICENSE="ISC openssl"
+SLOT="0/35" # reflects ABI of libcrypto.so and libssl.so
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86"
+IUSE="+asm static-libs"
+
+RDEPEND="!dev-libs/openssl:0"
+DEPEND="${RDEPEND}"
+PDEPEND="app-misc/ca-certificates"
+
+src_prepare() {
+ touch crypto/Makefile.in
+ sed -i \
+ -e '/^[ \t]*CFLAGS=/s#-g ##' \
+ -e '/^[ \t]*CFLAGS=/s#-g"#"#' \
+ -e '/^[ \t]*CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*CFLAGS=/s#-O2"#"#' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2"#"#' \
+ configure || die "fixing CFLAGS failed"
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable asm) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_test() {
+ emake check
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}
diff --git a/dev-libs/libressl/libressl-2.3.6.ebuild b/dev-libs/libressl/libressl-2.3.6.ebuild
new file mode 100644
index 000000000000..f65fed526d33
--- /dev/null
+++ b/dev-libs/libressl/libressl-2.3.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
+HOMEPAGE="http://www.libressl.org/"
+SRC_URI="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+
+LICENSE="ISC openssl"
+# Reflects ABI of libcrypto.so and libssl.so. Since these can differ,
+# we'll try to use the max of either. However, if either change between
+# versions, we have to change the subslot to trigger rebuild of consumers.
+SLOT="0/38"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86"
+IUSE="+asm static-libs"
+
+RDEPEND="!dev-libs/openssl:0"
+DEPEND="${RDEPEND}"
+PDEPEND="app-misc/ca-certificates"
+
+src_prepare() {
+ touch crypto/Makefile.in
+
+ sed -i \
+ -e '/^[ \t]*CFLAGS=/s#-g ##' \
+ -e '/^[ \t]*CFLAGS=/s#-g"#"#' \
+ -e '/^[ \t]*CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*CFLAGS=/s#-O2"#"#' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2"#"#' \
+ configure || die "fixing CFLAGS failed"
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable asm) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_test() {
+ emake check
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}
diff --git a/dev-libs/libressl/libressl-2.4.1.ebuild b/dev-libs/libressl/libressl-2.4.1.ebuild
new file mode 100644
index 000000000000..e6602882fd3a
--- /dev/null
+++ b/dev-libs/libressl/libressl-2.4.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
+HOMEPAGE="http://www.libressl.org/"
+SRC_URI="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+
+LICENSE="ISC openssl"
+# Reflects ABI of libcrypto.so and libssl.so. Since these can differ,
+# we'll try to use the max of either. However, if either change between
+# versions, we have to change the subslot to trigger rebuild of consumers.
+SLOT="0/39"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86"
+IUSE="+asm static-libs"
+
+RDEPEND="!dev-libs/openssl:0"
+DEPEND="${RDEPEND}"
+PDEPEND="app-misc/ca-certificates"
+
+src_prepare() {
+ touch crypto/Makefile.in
+
+ sed -i \
+ -e '/^[ \t]*CFLAGS=/s#-g ##' \
+ -e '/^[ \t]*CFLAGS=/s#-g"#"#' \
+ -e '/^[ \t]*CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*CFLAGS=/s#-O2"#"#' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2"#"#' \
+ configure || die "fixing CFLAGS failed"
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable asm) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_test() {
+ emake check
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}