summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/raft/files/raft-0.9.25-Always-skip-init-oom-test.patch31
-rw-r--r--dev-libs/raft/raft-0.9.25.ebuild4
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-libs/raft/files/raft-0.9.25-Always-skip-init-oom-test.patch b/dev-libs/raft/files/raft-0.9.25-Always-skip-init-oom-test.patch
new file mode 100644
index 000000000000..7a22682c2e03
--- /dev/null
+++ b/dev-libs/raft/files/raft-0.9.25-Always-skip-init-oom-test.patch
@@ -0,0 +1,31 @@
+commit e0948518f6eedad85c7705fb3963cfdda3627d8f
+Author: Reto Gantenbein <reto.gantenbein@linuxmonk.ch>
+Date: Thu Oct 22 00:19:31 2020 +0200
+
+ Always skip init/oom test
+
+ The RPM package build in COPR is being executed on a tmpfs which
+ always results in a failure of this test:
+
+ init/oom
+ heap-fault-delay=1, heap-fault-repeat=1 [ ERROR ]
+ Error: test/integration/test_uv_init.c:156: assertion failed: _rv == 1 (0 == 1)
+
+ Instead only for certain architectures we always skip this test.
+ For more informations see https://github.com/ganto/copr-lxc4/issues/8
+
+diff --git a/test/integration/test_uv_init.c b/test/integration/test_uv_init.c
+index 8c9b5f7..57db7f3 100644
+--- a/test/integration/test_uv_init.c
++++ b/test/integration/test_uv_init.c
+@@ -144,10 +144,8 @@ static MunitParameterEnum oomParams[] = {
+ TEST(init, oom, setUp, tearDown, 0, oomParams)
+ {
+ struct fixture *f = data;
+-#if defined(__i686__)
+ /* XXX: tmpfs seems to not support O_DIRECT */
+ return MUNIT_SKIP;
+-#endif
+ #if defined(__powerpc64__)
+ /* XXX: fails on ppc64el */
+ return MUNIT_SKIP;
diff --git a/dev-libs/raft/raft-0.9.25.ebuild b/dev-libs/raft/raft-0.9.25.ebuild
index b1d2d3822b20..b5f0f01804eb 100644
--- a/dev-libs/raft/raft-0.9.25.ebuild
+++ b/dev-libs/raft/raft-0.9.25.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,6 +18,8 @@ RESTRICT="!test? ( test )"
DEPEND="dev-libs/libuv"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}"/raft-0.9.25-Always-skip-init-oom-test.patch )
+
src_prepare() {
default