summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/lua-cjson/lua-cjson-2.1.0.8-r100.ebuild')
-rw-r--r--dev-lua/lua-cjson/lua-cjson-2.1.0.8-r100.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-lua/lua-cjson/lua-cjson-2.1.0.8-r100.ebuild b/dev-lua/lua-cjson/lua-cjson-2.1.0.8-r100.ebuild
index c7ff3172c0be..c6ca85c83961 100644
--- a/dev-lua/lua-cjson/lua-cjson-2.1.0.8-r100.ebuild
+++ b/dev-lua/lua-cjson/lua-cjson-2.1.0.8-r100.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-LUA_COMPAT=( lua5-{1..3} luajit )
+LUA_COMPAT=( lua5-{1..4} luajit )
inherit lua toolchain-funcs
@@ -61,7 +61,7 @@ src_compile() {
}
lua_src_test() {
- if ! [[ ${ELUA} == "lua5.3" ]]; then
+ if ! [[ ${ELUA} == "lua5.3" || ${ELUA} == "lua5.4" ]]; then
pushd "${BUILD_DIR}" || die
cd tests || die