summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/luacov/luacov-0.8.ebuild')
-rw-r--r--dev-lua/luacov/luacov-0.8.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-lua/luacov/luacov-0.8.ebuild b/dev-lua/luacov/luacov-0.8.ebuild
new file mode 100644
index 000000000000..d1fd6c10266d
--- /dev/null
+++ b/dev-lua/luacov/luacov-0.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="LuaCov is a simple coverage analyzer for Lua scripts"
+HOMEPAGE="https://github.com/keplerproject/luacov"
+SRC_URI="https://github.com/keplerproject/luacov/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+COMMON_DEPEND=">=dev-lang/lua-5.1"
+DEPEND="${COMMON_DEPEND}
+virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PF}-fix-makefile.patch
+}
+
+src_compile() {
+ return 0
+}
+
+src_install() {
+ emake DESTDIR="${ED}" \
+ PREFIX=/usr \
+ LUADIR="$(pkg-config --variable INSTALL_LMOD lua)" install
+dohtml -r doc/*
+ dodoc -r examples
+}