summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/luacrypto')
-rw-r--r--dev-lua/luacrypto/Manifest1
-rw-r--r--dev-lua/luacrypto/files/luacrypto-0.3.2-lualibdir.patch11
-rw-r--r--dev-lua/luacrypto/luacrypto-0.3.2-r1.ebuild39
-rw-r--r--dev-lua/luacrypto/metadata.xml10
4 files changed, 61 insertions, 0 deletions
diff --git a/dev-lua/luacrypto/Manifest b/dev-lua/luacrypto/Manifest
new file mode 100644
index 000000000000..717249fa572b
--- /dev/null
+++ b/dev-lua/luacrypto/Manifest
@@ -0,0 +1 @@
+DIST luacrypto-0.3.2.tar.gz 374363 SHA256 63c5d7e2539779039114335b9a8f149d63382c4db298d69e70488a0108143bb4 SHA512 4cb20d2cc348a11f140210dffb803629034c72cc7232590f4488f559d5c7233e0c41e56fcd0863959ac0b07e64c9aa79ea573e4126fdc11bc3f1b3b49d13343e WHIRLPOOL afb2ab562f4d983396debc68b48bbe295f90d9dd38fad5b9a474d7391783511ab4358e077ca3c383ba365766bc197685c5787686385c80a38425b89870542924
diff --git a/dev-lua/luacrypto/files/luacrypto-0.3.2-lualibdir.patch b/dev-lua/luacrypto/files/luacrypto-0.3.2-lualibdir.patch
new file mode 100644
index 000000000000..461e066865c2
--- /dev/null
+++ b/dev-lua/luacrypto/files/luacrypto-0.3.2-lualibdir.patch
@@ -0,0 +1,11 @@
+--- luacrypto-0.3.2/configure.ac
++++ luacrypto-0.3.2/configure.ac
+@@ -31,7 +31,7 @@
+ PKG_CHECK_MODULES([LUA], [lua])
+
+ # lua libdir
+-LUALIBDIR="`$PKGCONFIG --variable=libdir lua`"
++LUALIBDIR="`$PKGCONFIG --variable=INSTALL_CMOD lua`"
+
+ # dest of headers
+ CRYPTOINC="${includedir}/${PACKAGE_NAME}"
diff --git a/dev-lua/luacrypto/luacrypto-0.3.2-r1.ebuild b/dev-lua/luacrypto/luacrypto-0.3.2-r1.ebuild
new file mode 100644
index 000000000000..a431caab2d5b
--- /dev/null
+++ b/dev-lua/luacrypto/luacrypto-0.3.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="Lua frontend to OpenSSL"
+HOMEPAGE="http://mkottman.github.io/luacrypto/ https://github.com/mkottman/luacrypto/"
+SRC_URI="https://github.com/mkottman/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-lang/lua-5.1:0
+ dev-libs/openssl:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-lualibdir.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf --htmldir=/usr/share/doc/${PF}/html
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+}
diff --git a/dev-lua/luacrypto/metadata.xml b/dev-lua/luacrypto/metadata.xml
new file mode 100644
index 000000000000..48756ac193f6
--- /dev/null
+++ b/dev-lua/luacrypto/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mkottman/luacrypto</remote-id>
+ </upstream>
+</pkgmetadata>