summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/base/base-0.14.1-r1.ebuild')
-rw-r--r--dev-ml/base/base-0.14.1-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ml/base/base-0.14.1-r1.ebuild b/dev-ml/base/base-0.14.1-r1.ebuild
new file mode 100644
index 000000000000..ec1b96faf89e
--- /dev/null
+++ b/dev-ml/base/base-0.14.1-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Standard library for OCaml"
+HOMEPAGE="https://github.com/janestreet/base"
+SRC_URI="https://github.com/janestreet/base/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-ml/sexplib0-0.14.0:= <dev-ml/sexplib0-0.15.0:=
+ dev-ml/dune-configurator:=
+"
+DEPEND="${RDEPEND}"