summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/cstruct/cstruct-6.2.0-r1.ebuild')
-rw-r--r--dev-ml/cstruct/cstruct-6.2.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/cstruct/cstruct-6.2.0-r1.ebuild b/dev-ml/cstruct/cstruct-6.2.0-r1.ebuild
new file mode 100644
index 000000000000..b397c637c091
--- /dev/null
+++ b/dev-ml/cstruct/cstruct-6.2.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Access C-like structures directly from OCaml"
+HOMEPAGE="https://github.com/mirage/ocaml-cstruct"
+SRC_URI="https://github.com/mirage/ocaml-cstruct/releases/download/v${PV}/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? (
+ dev-ml/alcotest
+ dev-ml/cppo
+ dev-ml/ocaml-migrate-parsetree
+ dev-ml/ppx_sexp_conv
+ dev-ml/ppxlib
+ dev-ml/sexplib
+ )
+"
+
+src_compile() {
+ dune-compile ${PN}
+}