summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/dose3/dose3-3.3.ebuild')
-rw-r--r--dev-ml/dose3/dose3-3.3.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/dev-ml/dose3/dose3-3.3.ebuild b/dev-ml/dose3/dose3-3.3.ebuild
index 808c7afc8e27..f9ac6f602445 100644
--- a/dev-ml/dose3/dose3-3.3.ebuild
+++ b/dev-ml/dose3/dose3-3.3.ebuild
@@ -4,6 +4,8 @@
EAPI=5
+inherit eutils
+
MY_P="${P/_beta/-beta}"
DESCRIPTION="Library and a collection of tools to perform la large spectrum of analysis on package repositories"
HOMEPAGE="http://dose.gforge.inria.fr/public_html/"
@@ -39,6 +41,7 @@ S="${WORKDIR}/${MY_P}"
src_prepare() {
sed -e 's/INSTALLOPTS=-s/INSTALLOPTS=/' -i Makefile.config.in || die
+ has_version '>=dev-ml/extlib-1.7' && epatch "${FILESDIR}/extlib.patch"
}
src_configure() {