summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/lwt/lwt-2.5.2-r1.ebuild')
-rw-r--r--dev-ml/lwt/lwt-2.5.2-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-ml/lwt/lwt-2.5.2-r1.ebuild b/dev-ml/lwt/lwt-2.5.2-r1.ebuild
new file mode 100644
index 000000000000..032f01a6f8e4
--- /dev/null
+++ b/dev-ml/lwt/lwt-2.5.2-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+# fails to build
+#OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Cooperative light-weight thread library for OCaml"
+SRC_URI="https://github.com/ocsigen/lwt/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="http://ocsigen.org/lwt"
+
+IUSE="gtk +ppx +react +ssl"
+
+DEPEND="react? ( >=dev-ml/react-1.2:= )
+ dev-libs/libev
+ ssl? ( >=dev-ml/ocaml-ssl-0.4.0:= )
+ gtk? ( dev-ml/lablgtk:= dev-libs/glib:2 )
+ ppx? ( dev-ml/ppx_tools:= )
+ dev-ml/camlp4:="
+
+RDEPEND="${DEPEND}
+ !<www-servers/ocsigen-1.1"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2.1-with-linking-exception"
+KEYWORDS="~amd64 ~x86-fbsd"
+
+DOCS=( "CHANGES" "README.md" )
+
+src_configure() {
+ oasis_configure_opts="$(use_enable gtk glib)
+ $(use_enable react)
+ $(use_enable ssl)
+ --enable-camlp4
+ $(use_enable ppx)" \
+ oasis_src_configure
+}