summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/markup/markup-1.0.0.ebuild')
-rw-r--r--dev-ml/markup/markup-1.0.0.ebuild18
1 files changed, 3 insertions, 15 deletions
diff --git a/dev-ml/markup/markup-1.0.0.ebuild b/dev-ml/markup/markup-1.0.0.ebuild
index be349d21561b..011aaf40c7e4 100644
--- a/dev-ml/markup/markup-1.0.0.ebuild
+++ b/dev-ml/markup/markup-1.0.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit opam multiprocessing
+inherit dune
DESCRIPTION="Error-recovering streaming HTML5 and XML parsers"
HOMEPAGE="https://github.com/aantron/markup.ml"
@@ -12,19 +12,7 @@ SRC_URI="https://github.com/aantron/markup.ml/archive/${PV}.tar.gz -> ${P}.tar.g
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="test"
-
-RDEPEND="dev-lang/ocaml:="
-BDEPEND=">=dev-ml/dune-2.7
- dev-lang/ocaml"
-DEPEND="${RDEPEND}"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
S="${WORKDIR}/${PN}.ml-${PV}"
-
-src_compile() {
- dune build -p "${PN}" -j $(makeopts_jobs) @install || die
-}
-
-src_test() {
- dune runtest -p "${PN}" -j $(makeopts_jobs) || die
-}