summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-dispatch')
-rw-r--r--dev-ml/ocaml-dispatch/Manifest2
-rw-r--r--dev-ml/ocaml-dispatch/metadata.xml8
-rw-r--r--dev-ml/ocaml-dispatch/ocaml-dispatch-0.3.0.ebuild34
-rw-r--r--dev-ml/ocaml-dispatch/ocaml-dispatch-0.4.0.ebuild44
4 files changed, 0 insertions, 88 deletions
diff --git a/dev-ml/ocaml-dispatch/Manifest b/dev-ml/ocaml-dispatch/Manifest
deleted file mode 100644
index d6eb8d0571b6..000000000000
--- a/dev-ml/ocaml-dispatch/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST ocaml-dispatch-0.3.0.tar.gz 51453 BLAKE2B bd7965396a82a9f767abd05079496a5e0c1f12c3fe02d8c1d79b41db10010eefd89edf3351d8d05f132f0df3c3ab79533902a98752e571bfd09d4f2798f1db57 SHA512 0f09eae45a2ecae27d07e247b6a47f307e074342e337e7be262f5183f77090f0aef81fb5c0bf499732bd0a711d4d51775cbcea5e463011f43a1777582d78806b
-DIST ocaml-dispatch-0.4.0.tar.gz 7554 BLAKE2B 9bbe102df8a27642cbf54ad876caa276ba966ca3b19af53ac8f957799d0ca98b030c0d5ec055cc2868b2c374d71371c6e91ef0b89f4b5a072fbe2c47133df919 SHA512 d5318bda4079c21820fce5b21d178ed88fd0535a5cdc559dd6ceeb4d06ffb08456ee5aec1e56efd40b6d4f456f7d5c7eda17dc728666e6514dc936898b605b36
diff --git a/dev-ml/ocaml-dispatch/metadata.xml b/dev-ml/ocaml-dispatch/metadata.xml
deleted file mode 100644
index cf004079a542..000000000000
--- a/dev-ml/ocaml-dispatch/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="github">inhabitedtype/ocaml-dispatch</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-ml/ocaml-dispatch/ocaml-dispatch-0.3.0.ebuild b/dev-ml/ocaml-dispatch/ocaml-dispatch-0.3.0.ebuild
deleted file mode 100644
index 0056e666f79f..000000000000
--- a/dev-ml/ocaml-dispatch/ocaml-dispatch-0.3.0.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-OASIS_BUILD_DOCS=1
-OASIS_BUILD_TESTS=1
-
-inherit oasis
-
-DESCRIPTION="Path-based dispatching for client- and server-side applications"
-HOMEPAGE="https://github.com/inhabitedtype/ocaml-dispatch"
-SRC_URI="https://github.com/inhabitedtype/ocaml-dispatch/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="javascript"
-
-DEPEND="
- javascript? ( dev-ml/js_of_ocaml:=[ppx,ocamlopt?] )
- dev-ml/result:=[ocamlopt?]
-"
-RDEPEND="${DEPEND}"
-DEPEND="${DEPEND}
- test? ( dev-ml/ounit[ocamlopt?] )
-"
-
-DOCS=( "README.md" )
-
-src_configure() {
- oasis_configure_opts="$(use_enable javascript js-of-ocaml)" \
- oasis_src_configure
-}
diff --git a/dev-ml/ocaml-dispatch/ocaml-dispatch-0.4.0.ebuild b/dev-ml/ocaml-dispatch/ocaml-dispatch-0.4.0.ebuild
deleted file mode 100644
index 2e502161f235..000000000000
--- a/dev-ml/ocaml-dispatch/ocaml-dispatch-0.4.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit findlib
-
-DESCRIPTION="Path-based dispatching for client- and server-side applications"
-HOMEPAGE="https://github.com/inhabitedtype/ocaml-dispatch"
-SRC_URI="https://github.com/inhabitedtype/ocaml-dispatch/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-ml/result:=
- dev-lang/ocaml:=
-"
-RDEPEND="${DEPEND}"
-DEPEND="${DEPEND}
- dev-ml/jbuilder
- dev-ml/opam
- test? ( dev-ml/ounit )
-"
-
-src_compile() {
- jbuilder build -p dispatch || die
-}
-
-oinstall() {
- opam-installer -i \
- --prefix="${ED}/usr" \
- --libdir="${D}/$(ocamlc -where)" \
- --docdir="${ED}/usr/share/doc/${PF}" \
- --mandir="${ED}/usr/share/man" \
- ${1}.install || die
-}
-
-src_install() {
- oinstall dispatch
-}