summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocamlgraph')
-rw-r--r--dev-ml/ocamlgraph/Manifest2
-rw-r--r--dev-ml/ocamlgraph/files/ocamlgraph-0.99b-installfindlib.patch21
-rw-r--r--dev-ml/ocamlgraph/files/ocamlgraph-1.8.5-installfindlib.patch38
-rw-r--r--dev-ml/ocamlgraph/metadata.xml5
-rw-r--r--dev-ml/ocamlgraph/ocamlgraph-0.99b.ebuild56
-rw-r--r--dev-ml/ocamlgraph/ocamlgraph-1.8.5.ebuild62
6 files changed, 184 insertions, 0 deletions
diff --git a/dev-ml/ocamlgraph/Manifest b/dev-ml/ocamlgraph/Manifest
new file mode 100644
index 000000000000..8b3693b76162
--- /dev/null
+++ b/dev-ml/ocamlgraph/Manifest
@@ -0,0 +1,2 @@
+DIST ocamlgraph-0.99b.tar.gz 175958 SHA256 c4a646cfd152791268d9c2716c5e1c55bf3f39e8637a85f3c3937e3dd4dafec7 SHA512 1301d766679f59714d2adee1cb8cf31ebcc23f1fd425927dc6fd0c23e18849aaf93f04f3d694ea2e05f9570e8ec03734d96abb2668339b45b273e9d78197c0f9 WHIRLPOOL 96a805dcc9ccab532d6590b112f61f255bb7e320990497abea49fed908735671558fa2d83e586322cac7249bf206830ca816efac25ee64776376a49da7f4f341
+DIST ocamlgraph-1.8.5.tar.gz 269438 SHA256 d167466435a155c779d5ec25b2db83ad851feb42ebc37dca8ffa345ddaefb82f SHA512 e3bf7f43f7b5167cbd23ea44a510d1a569d35771882ab7ae83bacc73822c5f4c944f62c95e0efa813b765e1e385a6b3ebff342cbf1c5589c73d022b8591a52dc WHIRLPOOL d25e124c2814e3196a441e706ca91a0429ab48669309c5dec2ae6697e48064ce54efc9d24440d9e52f3a1af8cfdd5c3ae04cd549fde4e9abc860a3506bd2de8d
diff --git a/dev-ml/ocamlgraph/files/ocamlgraph-0.99b-installfindlib.patch b/dev-ml/ocamlgraph/files/ocamlgraph-0.99b-installfindlib.patch
new file mode 100644
index 000000000000..5c68c0c15a2d
--- /dev/null
+++ b/dev-ml/ocamlgraph/files/ocamlgraph-0.99b-installfindlib.patch
@@ -0,0 +1,21 @@
+Index: ocamlgraph-0.99b/Makefile.in
+===================================================================
+--- ocamlgraph-0.99b.orig/Makefile.in
++++ ocamlgraph-0.99b/Makefile.in
+@@ -208,10 +208,14 @@ install-byte:
+ install-opt: install-byte
+ cp -f graph$(LIBEXT) graph.cmx $(CMXA) "$(OCAMLLIB)"
+
++ifneq ($(OCAMLOPT),no)
++INSTALL_OPT=graph$(LIBEXT) graph.cmx $(CMXA)
++endif
++
+ install-findlib: META
+ ifdef OCAMLFIND
+- $(OCAMLFIND) install ocamlgraph META *.mli \
+- graph$(LIBEXT) graph.cmx graph.cmo graph.cmi $(CMA) $(CMXA)
++ $(OCAMLFIND) install ocamlgraph META src/*.mli lib/*.mli \
++ $(INSTALL_OPT) graph.cmo graph.cmi $(CMA)
+ endif
+
+ # documentation
diff --git a/dev-ml/ocamlgraph/files/ocamlgraph-1.8.5-installfindlib.patch b/dev-ml/ocamlgraph/files/ocamlgraph-1.8.5-installfindlib.patch
new file mode 100644
index 000000000000..30eb937069d0
--- /dev/null
+++ b/dev-ml/ocamlgraph/files/ocamlgraph-1.8.5-installfindlib.patch
@@ -0,0 +1,38 @@
+Index: ocamlgraph-1.8.5/Makefile.in
+===================================================================
+--- ocamlgraph-1.8.5.orig/Makefile.in
++++ ocamlgraph-1.8.5/Makefile.in
+@@ -417,21 +417,25 @@ ifeq (@LABLGNOMECANVAS@,yes)
+ cp -f $(VIEWER_DIR)/*.mli $(DGRAPH_DIR)/*.mli $(INSTALL_LIBDIR)
+ endif
+
++ifneq ($(WANT_OCAMLOPT),no)
++INSTALL_OPT=graph$(LIBEXT) graph.cmx $(CMXA)
++INSTALL_GTK_OPT=$(VIEWER_CMXLIB) $(VIEWER_CMXLIB:.cmx=.o) $(DGRAPH_CMXLIB) $(DGRAPH_CMXLIB:.cmx=.o) graph$(OBJEXT)
++endif
++
+ install-findlib: META
+ ifdef OCAMLFIND
+-ifeq (@LABLGNOMECANVAS@,yes)
++ifeq ($(WANT_GTK),yes)
+ $(OCAMLFIND) install ocamlgraph META \
+ $(SRCDIR)/*.mli $(VIEWER_DIR)/*.mli $(DGRAPH_DIR)/*.mli \
+- graph$(OBJEXT) graph$(LIBEXT) graph.cmx graph.cmo graph.cmi \
+- $(CMA) $(CMXA) \
+- $(VIEWER_CMXLIB) $(VIEWER_CMOLIB) $(VIEWER_CMILIB) \
+- $(VIEWER_CMXLIB:.cmx=.o) \
+- $(DGRAPH_CMXLIB) $(DGRAPH_CMOLIB) $(DGRAPH_CMILIB) \
+- $(DGRAPH_CMXLIB:.cmx=.o)
++ $(INSTALL_OPT) graph.cmo graph.cmi \
++ $(CMA) \
++ $(INSTALL_GTK_OPT) \
++ $(VIEWER_CMOLIB) $(VIEWER_CMILIB) \
++ $(DGRAPH_CMOLIB) $(DGRAPH_CMILIB)
+ else
+ $(OCAMLFIND) install ocamlgraph META \
+ $(SRCDIR)/*.mli $(VIEWER_DIR)/*.mli $(DGRAPH_DIR)/*.mli \
+- graph$(LIBEXT) graph.cmx graph.cmo graph.cmi $(CMA) $(CMXA)
++ $(INSTALL_OPT) graph.cmo graph.cmi $(CMA)
+ endif
+ endif
+
diff --git a/dev-ml/ocamlgraph/metadata.xml b/dev-ml/ocamlgraph/metadata.xml
new file mode 100644
index 000000000000..849ed8ebf13d
--- /dev/null
+++ b/dev-ml/ocamlgraph/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+</pkgmetadata>
diff --git a/dev-ml/ocamlgraph/ocamlgraph-0.99b.ebuild b/dev-ml/ocamlgraph/ocamlgraph-0.99b.ebuild
new file mode 100644
index 000000000000..c11ed0e2ed1d
--- /dev/null
+++ b/dev-ml/ocamlgraph/ocamlgraph-0.99b.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="O'Caml Graph library"
+HOMEPAGE="http://www.lri.fr/~filliatr/ocamlgraph/"
+SRC_URI="http://www.lri.fr/~filliatr/ftp/ocamlgraph/${P}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ppc x86"
+RDEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ gtk? ( dev-ml/lablgtk:=[gnomecanvas,ocamlopt?] )"
+DEPEND="${RDEPEND}
+ doc? ( dev-tex/hevea dev-ml/ocamlweb )"
+IUSE="doc examples gtk +ocamlopt"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-installfindlib.patch"
+}
+
+src_compile() {
+ emake -j1
+
+ if use doc; then
+ emake doc
+ fi
+ if use gtk; then
+ emake -j1 editor
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ emake install-findlib
+
+ if use gtk; then
+ if use ocamlopt; then
+ newbin editor/editor.opt ocamlgraph_editor
+ else
+ newbin editor/editor.byte ocamlgraph_editor
+ fi
+ fi
+ dodoc README CREDITS FAQ CHANGES
+ if use doc; then
+ dohtml doc/*
+ fi
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-ml/ocamlgraph/ocamlgraph-1.8.5.ebuild b/dev-ml/ocamlgraph/ocamlgraph-1.8.5.ebuild
new file mode 100644
index 000000000000..efa355e87bb1
--- /dev/null
+++ b/dev-ml/ocamlgraph/ocamlgraph-1.8.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="O'Caml Graph library"
+HOMEPAGE="http://ocamlgraph.lri.fr/index.en.html"
+SRC_URI="http://ocamlgraph.lri.fr/download/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86"
+RDEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ gtk? ( dev-ml/lablgtk:=[gnomecanvas,ocamlopt?] )"
+DEPEND="${RDEPEND}
+ doc? ( dev-tex/hevea dev-ml/ocamlweb )"
+IUSE="doc examples gtk +ocamlopt"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-installfindlib.patch"
+}
+
+src_compile() {
+ emake byte
+ use ocamlopt && emake opt
+
+ if use doc; then
+ emake doc
+ fi
+
+ if use gtk; then
+ emake OCAMLBEST=$(usex ocamlopt opt byte) viewer dgraph editor
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ use ocamlopt || export WANT_OCAMLOPT=no
+ use gtk && export WANT_GTK=yes
+ emake install-findlib
+
+ if use gtk ; then
+ local ext=byte
+ use ocamlopt && ext=opt
+ newbin dgraph/dgraph.${ext} ${PN}-dgraph
+ newbin editor/editor.${ext} ${PN}-editor
+ newbin view_graph/viewgraph.${ext} ${PN}-viewgraph
+ fi
+
+ dodoc README CREDITS FAQ CHANGES
+ if use doc; then
+ dohtml doc/*
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}