summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/opam-solver/opam-solver-2.0.10.ebuild')
-rw-r--r--dev-ml/opam-solver/opam-solver-2.0.10.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-ml/opam-solver/opam-solver-2.0.10.ebuild b/dev-ml/opam-solver/opam-solver-2.0.10.ebuild
new file mode 100644
index 000000000000..3ee659981fd5
--- /dev/null
+++ b/dev-ml/opam-solver/opam-solver-2.0.10.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="opam solver"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/archive/${PV/_/-}.tar.gz -> opam-${PV}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/dev-ml/opam/opam-2.1.0-dose3-6.patch.xz"
+S="${WORKDIR}/opam-${PV/_/-}"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ~dev-ml/opam-format-${PV}:=
+ dev-ml/opam-file-format:=
+ dev-ml/re:=
+ >=dev-ml/mccs-1.1.4:=
+ >=dev-ml/dose3-6.0:=
+ dev-ml/cudf:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/opam-client )"
+
+PATCHES=( "${WORKDIR}"/opam-2.1.0-dose3-6.patch )
+
+src_prepare() {
+ default
+ cat <<- EOF >> "${S}/dune"
+ (env
+ (dev
+ (flags (:standard -warn-error -3-9-33)))
+ (release
+ (flags (:standard -warn-error -3-9-33))))
+ EOF
+}