summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppxfind/ppxfind-1.4.ebuild')
-rw-r--r--dev-ml/ppxfind/ppxfind-1.4.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ml/ppxfind/ppxfind-1.4.ebuild b/dev-ml/ppxfind/ppxfind-1.4.ebuild
new file mode 100644
index 000000000000..6f6e5d665075
--- /dev/null
+++ b/dev-ml/ppxfind/ppxfind-1.4.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="ocamlfind ppx tool"
+HOMEPAGE="https://github.com/diml/ppxfind"
+SRC_URI="https://github.com/diml/ppxfind/releases/download/${PV}/${P}.tbz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/findlib:=
+"
+RDEPEND="${DEPEND}"