summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/merlin/Manifest2
-rw-r--r--dev-ml/merlin/merlin-4.3.1-r3.ebuild84
2 files changed, 0 insertions, 86 deletions
diff --git a/dev-ml/merlin/Manifest b/dev-ml/merlin/Manifest
index b9cfc9204251..4da55eef03ef 100644
--- a/dev-ml/merlin/Manifest
+++ b/dev-ml/merlin/Manifest
@@ -1,5 +1,3 @@
-DIST merlin-4.3.1-411.tar.gz 1626551 BLAKE2B c4340ff9b50c72208c4cb13d13e26f36463d7c257530d183a293eaaf3d86aaa71745d8154bb5c0e2149003b3cbe5a127fb6187e7bb7fa7024924fd239f981cfc SHA512 bcbba0c1bb1c84eef7becc4a537e1c2a4bd370a33333bfba1029c82fa8b1d9cdf367f98779fe3329286e418c41b06b49bfe796f5cf8058bcd189b4f33aad1abf
-DIST merlin-4.3.1-ocaml-4.12.patch.gz 818559 BLAKE2B accf65bd5d5798bafe2be022d685da8f829aa9a9c98784420d8a62646d80ab73d1e189e3601266e09eebd4732ae241e8d11dc9663adac3b03a555db663a6d649 SHA512 8823b6e30e49ab3cf35a78063066f01aa7dcbc9174d45b0fed94a3f50e388c35e7ac810c5548c57d7bcf9304b045c483080496865b011269913120a5509a1149
DIST merlin-4.5-411.tbz 1316537 BLAKE2B 8850ea6b15819a178f763d8b55fecca9104cec5097c39afad7dc8b59543d961d7aa4a86590ebb59a3066d1f6630f11284e24835398ab967f45a52faf004477f1 SHA512 9e68ebabdc0cc398edcd255516070d6459f3bf5738c0dbe332c11c6bc4070e7bf340bc086fa2ea58597972ebe9d15860ecd0e549444809be809f0509b41652c2
DIST merlin-4.5-412.tbz 1765436 BLAKE2B eaed065a2814f4c1bfc5337d026c7c42287b8cbbe50097415a983f7fdd7323f4c88f3b8c8cff4ca88a0813204617f39807709a6703fd618269eca6063b3c47b1 SHA512 f9edc3e1c9f753d7bacbdf1b92c118b54f9e9eff0bf752a2b44f39a2f7ecc76c4cd3bbe9227e910aea8b5ea947e8fe1b8d92ba0245fe47bc8cc2f45404cca973
DIST merlin-4.5-413.tbz 2290507 BLAKE2B 32aeda63caec645da8043c49ceaa0ea54d095b3e286f687b5f3da1b44d54bbc291d0358768d2180825cb620a91765da83d90b645151a694a4131788ab4438fbf SHA512 b1db98c38a97ca0eef3051ab2b5d1b158e757863de6908a830308e7ea7f960eebd64b1a60bf51b10b7ea2eea3141ee0917a7c3570b63f9faa2e3f69c5d6fe0c2
diff --git a/dev-ml/merlin/merlin-4.3.1-r3.ebuild b/dev-ml/merlin/merlin-4.3.1-r3.ebuild
deleted file mode 100644
index 2f3b6848a507..000000000000
--- a/dev-ml/merlin/merlin-4.3.1-r3.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# TODO: vim-plugin, although it's not clear how to make it work here
-inherit elisp-common dune
-
-DESCRIPTION="Context sensitive completion for OCaml in Vim and Emacs"
-HOMEPAGE="https://github.com/ocaml/merlin"
-SRC_URI="https://github.com/ocaml/merlin/archive/v${PV}-411.tar.gz -> ${P}-411.tar.gz
- https://dev.gentoo.org/~tupone/distfiles/${P}-ocaml-4.12.patch.gz"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="emacs +ocamlopt test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-ml/csexp:=
- <dev-ml/yojson-2:=
- dev-ml/menhir:=
- >=dev-ml/dune-2.9:=
- || (
- dev-lang/ocaml:0/4.11
- dev-lang/ocaml:0/4.12
- )
- emacs? (
- >=app-editors/emacs-23.1:*
- app-emacs/auto-complete
- app-emacs/company-mode
- )
-"
-DEPEND="${RDEPEND}
- test? ( app-misc/jq )"
-
-SITEFILE="50${PN}-gentoo.el"
-
-S="${WORKDIR}"/${P}-411
-
-src_prepare() {
- has_version "dev-lang/ocaml:0/4.12" && \
- eapply "${WORKDIR}"/${P}-ocaml-4.12.patch
- default
-
- # Handle installation via the eclass
- rm emacs/dune || die
-
- # rm failing test
- rm -r tests/test-dirs/locate/context-detection/cd-mod_constr.t || die
-}
-
-src_compile() {
- dune build @install || die
-
- if use emacs ; then
- # Build the emacs integration
- cd emacs || die
-
- # iedit isn't packaged yet
- rm merlin-iedit.el || die
-
- elisp-compile *.el
- fi
-}
-
-src_install() {
- dune_src_install
-
- if use emacs ; then
- cd "${S}/emacs" || die
- elisp-install ${PN} *.el *.elc
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}