summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/DBD-mysql/DBD-mysql-4.32.0-r2.ebuild')
-rw-r--r--dev-perl/DBD-mysql/DBD-mysql-4.32.0-r2.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-perl/DBD-mysql/DBD-mysql-4.32.0-r2.ebuild b/dev-perl/DBD-mysql/DBD-mysql-4.32.0-r2.ebuild
deleted file mode 100644
index cc31810f5513..000000000000
--- a/dev-perl/DBD-mysql/DBD-mysql-4.32.0-r2.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-MODULE_AUTHOR=CAPTTOFU
-MODULE_VERSION=4.032
-inherit eutils perl-module
-
-DESCRIPTION="The Perl DBD:mysql Module"
-
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="embedded test"
-
-RDEPEND="dev-perl/DBI
- dev-perl/Test-Deep
- virtual/libmysqlclient:=
- embedded? ( virtual/mysql[embedded] )
-"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-print_embedded_options.patch
-}
-
-src_configure() {
- if use test; then
- myconf="${myconf} --testdb=test \
- --testhost=localhost \
- --testuser=test \
- --testpassword=test"
- fi
- use embedded && myconf="${myconf} --force-embedded --embedded=mysql_config"
- perl-module_src_configure
-}
-
-src_test() {
- einfo
- einfo "If tests fail, you have to configure your MySQL instance to create"
- einfo "and grant some privileges to the test user."
- einfo "You can run the following commands at the MySQL prompt: "
- einfo "> CREATE USER 'test'@'localhost' IDENTIFIED BY 'test';"
- einfo "> CREATE DATABASE test;"
- einfo "> GRANT ALL PRIVILEGES ON test.* TO 'test'@'localhost';"
- einfo
- sleep 5
- perl-module_src_test
-}