summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/HTML-FormatText-WithLinks-AndTables/HTML-FormatText-WithLinks-AndTables-0.70.0-r2.ebuild')
-rw-r--r--dev-perl/HTML-FormatText-WithLinks-AndTables/HTML-FormatText-WithLinks-AndTables-0.70.0-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/HTML-FormatText-WithLinks-AndTables/HTML-FormatText-WithLinks-AndTables-0.70.0-r2.ebuild b/dev-perl/HTML-FormatText-WithLinks-AndTables/HTML-FormatText-WithLinks-AndTables-0.70.0-r2.ebuild
new file mode 100644
index 000000000000..0f8a1b956edf
--- /dev/null
+++ b/dev-perl/HTML-FormatText-WithLinks-AndTables/HTML-FormatText-WithLinks-AndTables-0.70.0-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=DALEEVANS
+DIST_VERSION=0.07
+inherit perl-module
+
+DESCRIPTION="Converts HTML to text with tables intact"
+
+SLOT="0"
+KEYWORDS="amd64 ~riscv"
+
+RDEPEND="
+ dev-perl/HTML-Formatter
+ dev-perl/HTML-FormatText-WithLinks
+ dev-perl/HTML-Tree
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"
+
+PATCHES=( "${FILESDIR}/README-INC.patch" )
+
+src_test() {
+ perl_rm_files t/author-*.t t/pod.t t/boilerplate.t
+ perl-module_src_test
+}