summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Video-ivtv/Video-ivtv-0.13-r3.ebuild')
-rw-r--r--dev-perl/Video-ivtv/Video-ivtv-0.13-r3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/Video-ivtv/Video-ivtv-0.13-r3.ebuild b/dev-perl/Video-ivtv/Video-ivtv-0.13-r3.ebuild
new file mode 100644
index 000000000000..77f1482fbe4b
--- /dev/null
+++ b/dev-perl/Video-ivtv/Video-ivtv-0.13-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit perl-module
+
+DESCRIPTION="Video::ivtv perl module, for use with ivtv-ptune"
+HOMEPAGE="http://ivtv.sourceforge.net"
+SRC_URI="mirror://sourceforge/ivtv/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ppc x86"
+
+RDEPEND=""
+BDEPEND="${RDEPEND}"
+
+src_configure() {
+ export OPTIMIZE="$CFLAGS"
+ perl-module_src_configure
+}
+
+# Requires /dev/video0 access, set DIST_TEST_OVERRIDE
+# to circumvent
+DIST_TEST="skip"
+
+src_test() {
+ ebegin "Compile testing Video::ivtv ${PV}"
+ perl -Mblib="${S}" -M"Video::ivtv ${PV} ()" -e1
+ if ! eend $?; then
+ echo
+ eerror "One or more modules failed compile:";
+ eerror " Video::ivtv ${PV}"
+ die "Failing due to module compilation errors";
+ fi
+ perl-module_src_test
+}