summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Path-IsDev/Manifest1
-rw-r--r--dev-perl/Path-IsDev/Path-IsDev-1.1.2.ebuild39
-rw-r--r--dev-perl/Path-IsDev/metadata.xml38
3 files changed, 78 insertions, 0 deletions
diff --git a/dev-perl/Path-IsDev/Manifest b/dev-perl/Path-IsDev/Manifest
new file mode 100644
index 000000000000..8989dadf7bc0
--- /dev/null
+++ b/dev-perl/Path-IsDev/Manifest
@@ -0,0 +1 @@
+DIST Path-IsDev-1.001002.tar.gz 190868 SHA256 95f98dd68cbda926eb0c2ed3061ac746a5f584af1bfe7206397f2e546960598d SHA512 fb9c24ad02899c501001615c315a62b620e243f2ad8c17acebce5571b0918a18c61549bd637c6d68ec2ebc9e739921c8168d99ef84bc8373f6c3c8726ac84125 WHIRLPOOL 024cc0d0b0322e595456b328bdafe2cb34aac48bc4124dcd2b3835ea30146476ae518a2bc97a54ed6719685c79cf0a1acf26fbb6312d41ada730eb942f3187f3
diff --git a/dev-perl/Path-IsDev/Path-IsDev-1.1.2.ebuild b/dev-perl/Path-IsDev/Path-IsDev-1.1.2.ebuild
new file mode 100644
index 000000000000..24e694b4c868
--- /dev/null
+++ b/dev-perl/Path-IsDev/Path-IsDev-1.1.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=KENTNL
+DIST_VERSION=1.001002
+inherit perl-module
+
+DESCRIPTION="Determine if a given Path resembles a development source tree"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test minimal"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/Class-Tiny-0.10.0
+ dev-perl/File-HomeDir
+ dev-perl/Module-Runtime
+ >=dev-perl/Path-Tiny-0.4.0
+ dev-perl/Role-Tiny
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Sub-Exporter
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ !minimal? ( >=virtual/perl-ExtUtils-MakeMaker-6.980.0 )
+ test? (
+ !minimal? (
+ >=virtual/perl-CPAN-Meta-2.120.900
+ >=virtual/perl-Test-Simple-1.1.3
+ )
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.890.0
+ )
+"
diff --git a/dev-perl/Path-IsDev/metadata.xml b/dev-perl/Path-IsDev/metadata.xml
new file mode 100644
index 000000000000..f11ae9c5955b
--- /dev/null
+++ b/dev-perl/Path-IsDev/metadata.xml
@@ -0,0 +1,38 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Path-IsDev</remote-id>
+ <remote-id type="cpan-module">Path::IsDev</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Heuristic::Changelog</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Heuristic::DevDirMarker</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Heuristic::META</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Heuristic::MYMETA</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Heuristic::Makefile</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Heuristic::TestDir</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Heuristic::Tool::Dzil</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Heuristic::Tool::MakeMaker</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Heuristic::Tool::ModuleBuild</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Heuristic::VCS::Git</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::HeuristicSet::Basic</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::NegativeHeuristic::HomeDir</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::NegativeHeuristic::IsDev::IgnoreFile</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::NegativeHeuristic::PerlINC</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Object</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Result</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Role::Heuristic</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Role::HeuristicSet</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Role::HeuristicSet::Simple</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Role::Matcher::Child::BaseName::MatchRegexp</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Role::Matcher::Child::BaseName::MatchRegexp::File</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Role::Matcher::Child::Exists::Any</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Role::Matcher::Child::Exists::Any::Dir</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Role::Matcher::Child::Exists::Any::File</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Role::Matcher::FullPath::Is::Any</remote-id>
+ <remote-id type="cpan-module">Path::IsDev::Role::NegativeHeuristic</remote-id>
+ </upstream>
+</pkgmetadata>