summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Math-Int128/Manifest1
-rw-r--r--dev-perl/Math-Int128/Math-Int128-0.220.0.ebuild38
-rw-r--r--dev-perl/Math-Int128/metadata.xml18
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-perl/Math-Int128/Manifest b/dev-perl/Math-Int128/Manifest
new file mode 100644
index 000000000000..02aafeea42e0
--- /dev/null
+++ b/dev-perl/Math-Int128/Manifest
@@ -0,0 +1 @@
+DIST Math-Int128-0.22.tar.gz 103698 BLAKE2B 1b23468c07c95681f7d94496edb7d0c26e7e4003b3ba74675bc0da0df1efd327e30ee88071242ffa6fa677de942c61c496eb346d00d59b27c461659a34231b46 SHA512 8384891e6a8e6e1696a7fe1d5da8c27c229e7926c6a16ac1114e812dce3a8a75f64d9d1128d2c63f17753c91c54c72dadbd3837e140624f9f1e47d462dccb74f
diff --git a/dev-perl/Math-Int128/Math-Int128-0.220.0.ebuild b/dev-perl/Math-Int128/Math-Int128-0.220.0.ebuild
new file mode 100644
index 000000000000..693b54d44fd5
--- /dev/null
+++ b/dev-perl/Math-Int128/Math-Int128-0.220.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=SALVA
+DIST_VERSION=0.22
+DIST_EXAMPLES=("benchmarks/*")
+inherit perl-module
+
+DESCRIPTION="Manipulate 128 bits integers in Perl"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND="
+ virtual/perl-Exporter
+ >=dev-perl/Math-Int64-0.510.0
+ virtual/perl-XSLoader
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-IO
+ virtual/perl-Math-BigInt
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"
+PERL_RM_FILES=(
+ "t/author-eol.t"
+ "t/author-no-tabs.t"
+ "t/author-pod-spell.t"
+ "t/release-cpan-changes.t"
+ "t/release-pod-syntax.t"
+ "t/release-portability.t"
+ "t/release-synopsis.t"
+)
diff --git a/dev-perl/Math-Int128/metadata.xml b/dev-perl/Math-Int128/metadata.xml
new file mode 100644
index 000000000000..39c3208db96f
--- /dev/null
+++ b/dev-perl/Math-Int128/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>hydrapolic@gmail.com</email>
+ <name>Tomáš Mózes</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Math-Int128</remote-id>
+ <remote-id type="cpan-module">Math::Int128</remote-id>
+ <remote-id type="cpan-module">Math::Int128::die_on_overflow</remote-id>
+ <remote-id type="cpan-module">Math::UInt128</remote-id>
+ </upstream>
+</pkgmetadata>