summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-File_Find')
-rw-r--r--dev-php/PEAR-File_Find/Manifest1
-rw-r--r--dev-php/PEAR-File_Find/PEAR-File_Find-1.3.3.ebuild45
-rw-r--r--dev-php/PEAR-File_Find/metadata.xml11
3 files changed, 53 insertions, 4 deletions
diff --git a/dev-php/PEAR-File_Find/Manifest b/dev-php/PEAR-File_Find/Manifest
index 534ba5d00fd7..0f3e397bcc5f 100644
--- a/dev-php/PEAR-File_Find/Manifest
+++ b/dev-php/PEAR-File_Find/Manifest
@@ -1 +1,2 @@
DIST File_Find-1.3.2.tgz 8157 SHA256 2e8837afebf64ac332c7e75c4df8941f7d181c5e51894a766d0dc553bb8121b8 SHA512 c764c3ad9b215a3c371414c94af191531ea714d5bc02b63debdf063b1a85aac952655ef64c92ce50c838bd49700956406fd4d314327f2d84c7c4b90258defce4 WHIRLPOOL c53757dbcf38df62249c431e2814da6a85d15145934c77c531b4d98051aa4eb10e7f72b2e9e5e3122588cb3372b4b1422c6d1f3a56cc28de45616da5326700e4
+DIST File_Find-1.3.3.tgz 8212 SHA256 a2fff81525a041ce54e5ec0941e7967e9faf109dd56e6f50b3111470f71c624b SHA512 f912e1f680c5869380791979bd33dabce0e95e40a84ee188052b2be8280de806fd117c11d66b98b7072724ecd9d57203ee5a32fe35705c337e73393fec075bb0 WHIRLPOOL 04e7909ceeb54f7f3dbe9c03943a7b044939277cb2333b147a273fe15d0a88918d13df9e34c7398b7388531eb02374a72152c3e4833ea6fda681ee204ab2d61e
diff --git a/dev-php/PEAR-File_Find/PEAR-File_Find-1.3.3.ebuild b/dev-php/PEAR-File_Find/PEAR-File_Find-1.3.3.ebuild
new file mode 100644
index 000000000000..3bfd60ffb677
--- /dev/null
+++ b/dev-php/PEAR-File_Find/PEAR-File_Find-1.3.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A class that facillitates the search of filesystems"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+# Really only needs PEAR-Exception at runtime.
+RDEPEND="dev-lang/php:*
+ dev-php/PEAR-PEAR"
+DEPEND="test? ( dev-php/PEAR-PEAR )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ eapply_user
+
+ # Without this sed, the test suite will try (and fail) to mess
+ # around in /tmp.
+ sed -i "s~'/tmp'~'${T}'~" tests/setup.php \
+ || die 'failed to fix temporary directory in tests/setup.php'
+}
+
+src_install() {
+ insinto /usr/share/php
+ doins -r File
+}
+
+src_test() {
+ # Requires the "pear" executable from dev-php/PEAR-PEAR.
+ pear run-tests tests || die
+
+ # The command succeeds regardless of whether or not the test suite
+ # passed, but this file is only written when there was a failure.
+ [[ -f run-tests.log ]] && die "test suite failed"
+}
diff --git a/dev-php/PEAR-File_Find/metadata.xml b/dev-php/PEAR-File_Find/metadata.xml
index aca42932b833..beddf160d50e 100644
--- a/dev-php/PEAR-File_Find/metadata.xml
+++ b/dev-php/PEAR-File_Find/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>php-bugs@gentoo.org</email>
- <name>PHP</name>
-</maintainer>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pear/File_Find</remote-id>
+ </upstream>
</pkgmetadata>