summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/pecl-imagick')
-rw-r--r--dev-php/pecl-imagick/Manifest2
-rw-r--r--dev-php/pecl-imagick/files/pecl-imagick-3.4.3-tsrm_ls-is-undeclared.patch18
-rw-r--r--dev-php/pecl-imagick/pecl-imagick-3.4.3.ebuild25
-rw-r--r--dev-php/pecl-imagick/pecl-imagick-3.4.3_p20181129.ebuild32
4 files changed, 0 insertions, 77 deletions
diff --git a/dev-php/pecl-imagick/Manifest b/dev-php/pecl-imagick/Manifest
index c4c62dbc90cf..1f064c2a8feb 100644
--- a/dev-php/pecl-imagick/Manifest
+++ b/dev-php/pecl-imagick/Manifest
@@ -1,3 +1 @@
-DIST imagick-3.4.3.tgz 245410 BLAKE2B 778c3b8ad3ad5e698044a832d71409eea220a82041544abeb88b59370d4b719388ce13b277d7aad84e67e40fcbbfa06d66a2458d4d9e8d33bb7358ab46368230 SHA512 2cb2b856cf83a78d3542cdf7c69554dcc063a0541e9092b24e5e1fbd8928066a4a3de154049d0202c35addbc5055ccfbb5910ae92f2f13da80ddfc025340ddcd
DIST imagick-3.4.4.tgz 253434 BLAKE2B 73ce21547881b60733dbc19ae83cd2e60135dbb4052ea723f1ee10b3759ce12065a0cab2a7e4923b78e9e68b12fd7b875c7d1bd7b2a14ce4e4d7ff5b9c7fbc06 SHA512 73145a1f095849c32760db2dfc4acc13c57d99a037d65eca9b0ddf8f8e81cf6d28a50f2614e44bae1d90b4f881a2e9a64926e0e3b9403e491fd903ffeb30c4b7
-DIST pecl-imagick-3.4.3_p20181129.tar.gz 260443 BLAKE2B 43d30514f5faeeaa5894e2eb51d5b2ebbe2940728c7770eec60c41c9f01f86f7423d87a71a9ad2068e388f3994c31e499940c2042994846a6b6ab66542c7ea53 SHA512 7f3719118849857d19b9a35a63de68d4e992780fd41231a041d6d152ab2f0abd3d8215ab2362a998f8fe6a733c087d3c3e5d09fa826480d621739e92f5aeabf2
diff --git a/dev-php/pecl-imagick/files/pecl-imagick-3.4.3-tsrm_ls-is-undeclared.patch b/dev-php/pecl-imagick/files/pecl-imagick-3.4.3-tsrm_ls-is-undeclared.patch
deleted file mode 100644
index ff0a1eb38885..000000000000
--- a/dev-php/pecl-imagick/files/pecl-imagick-3.4.3-tsrm_ls-is-undeclared.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-https://github.com/mkoppanen/imagick/issues/264
-
---- a/imagick_file.c
-+++ b/imagick_file.c
-@@ -160,11 +160,13 @@ static
- int php_imagick_read_image_using_imagemagick(php_imagick_object *intern, struct php_imagick_file_t *file, ImagickOperationType type TSRMLS_DC)
- {
-
-+#ifdef ZTS
- #ifndef ZEND_ENGINE_3
- #if PHP_VERSION_ID >= 50600
- // This suppresses an 'unused parameter' warning.
- (void)tsrm_ls;
- #endif
-+#endif
- #endif
-
- if (type == ImagickReadImage) {
diff --git a/dev-php/pecl-imagick/pecl-imagick-3.4.3.ebuild b/dev-php/pecl-imagick/pecl-imagick-3.4.3.ebuild
deleted file mode 100644
index 2552562115d0..000000000000
--- a/dev-php/pecl-imagick/pecl-imagick-3.4.3.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_PV="${PV/rc/RC}"
-
-USE_PHP="php5-6 php7-0 php7-1 php7-2"
-
-inherit php-ext-pecl-r3
-
-KEYWORDS="amd64 x86"
-
-DESCRIPTION="PHP wrapper for the ImageMagick library"
-LICENSE="PHP-3.01"
-SLOT="0"
-IUSE="examples test"
-
-# imagemagick[-openmp] is needed wrt bug 547922 and upstream
-# https://github.com/mkoppanen/imagick#openmp
-RDEPEND=">=media-gfx/imagemagick-6.2.4:=[-openmp]"
-DEPEND="${RDEPEND}
- test? ( >=media-gfx/imagemagick-6.2.4:=[jpeg,png,truetype] )"
-
-PHP_EXT_ECONF_ARGS="--with-imagick=${EPREFIX}/usr"
diff --git a/dev-php/pecl-imagick/pecl-imagick-3.4.3_p20181129.ebuild b/dev-php/pecl-imagick/pecl-imagick-3.4.3_p20181129.ebuild
deleted file mode 100644
index e1c86fc73437..000000000000
--- a/dev-php/pecl-imagick/pecl-imagick-3.4.3_p20181129.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-PHP_EXT_NAME="imagick"
-
-MY_COMMIT="d57a444766a321fa226266f51f1f42ee2cc29cc7"
-
-USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3"
-
-S="${WORKDIR}/imagick-${MY_COMMIT}"
-
-inherit php-ext-source-r3
-
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="PHP wrapper for the ImageMagick library"
-HOMEPAGE="https://pecl.php.net/imagick https://github.com/mkoppanen/imagick"
-SRC_URI="https://github.com/mkoppanen/imagick/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
-LICENSE="PHP-3.01"
-SLOT="0"
-IUSE="examples test"
-
-# imagemagick[-openmp] is needed wrt bug 547922 and upstream
-# https://github.com/mkoppanen/imagick#openmp
-RDEPEND=">=media-gfx/imagemagick-6.2.4:=[-openmp]"
-DEPEND="${RDEPEND}
- test? ( >=media-gfx/imagemagick-6.2.4:=[jpeg,png,truetype] )"
-
-PATCHES=( "${FILESDIR}"/${PN}-3.4.3-tsrm_ls-is-undeclared.patch )
-
-PHP_EXT_ECONF_ARGS="--with-imagick=${EPREFIX%/}/usr"