summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/pecl-redis/pecl-redis-3.1.1.ebuild')
-rw-r--r--dev-php/pecl-redis/pecl-redis-3.1.1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-php/pecl-redis/pecl-redis-3.1.1.ebuild b/dev-php/pecl-redis/pecl-redis-3.1.1.ebuild
new file mode 100644
index 000000000000..c6d5ee8620e2
--- /dev/null
+++ b/dev-php/pecl-redis/pecl-redis-3.1.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PHP_EXT_NAME="redis"
+USE_PHP="php5-6 php7-0 php7-1"
+DOCS=( arrays.markdown cluster.markdown README.markdown CREDITS )
+MY_P="${PN/pecl-/}-${PV/_rc/RC}"
+PHP_EXT_PECL_FILENAME="${MY_P}.tgz"
+PHP_EXT_S="${WORKDIR}/${MY_P}"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="PHP extension for interfacing with Redis"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="igbinary +session"
+
+DEPEND="igbinary? (
+ php_targets_php5-6? ( dev-php/igbinary[php_targets_php5-6] )
+ php_targets_php7-0? ( dev-php/igbinary[php_targets_php7-0] )
+ php_targets_php7-1? ( dev-php/igbinary[php_targets_php7-1] ) )"
+RDEPEND="${DEPEND} !dev-php/pecl-redis:7"
+
+# The test suite requires network access.
+RESTRICT=test
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-redis
+ $(use_enable igbinary redis-igbinary)
+ $(use_enable session redis-session)
+ )
+ php-ext-source-r3_src_configure
+}
+
+src_test(){
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ # Run tests for Redis class
+ ${PHPCLI} -d extension=modules/redis.so \
+ tests/TestRedis.php \
+ --class Redis \
+ --host ${PECL_REDIS_HOST} || die 'test suite failed'
+ done
+}