summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/phar-io-version/phar-io-version-3.0.4.ebuild')
-rw-r--r--dev-php/phar-io-version/phar-io-version-3.0.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-php/phar-io-version/phar-io-version-3.0.4.ebuild b/dev-php/phar-io-version/phar-io-version-3.0.4.ebuild
new file mode 100644
index 000000000000..1c28ee251730
--- /dev/null
+++ b/dev-php/phar-io-version/phar-io-version-3.0.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="Library for handling version information and constraints"
+HOMEPAGE="https://github.com/phar-io/version"
+SRC_URI="https://github.com/phar-io/version/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/version-${PV}"
+
+CDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-7.2:*"
+
+BDEPEND="dev-php/theseer-Autoload"
+
+RDEPEND="${CDEPEND}"
+
+src_prepare() {
+ default
+
+ phpab \
+ --output src/autoload.php \
+ --template fedora2 \
+ --basedir src \
+ src \
+ || die
+}
+
+src_install() {
+ insinto /usr/share/php/PharIo/Version
+ doins src/*.php
+ dodoc README.md
+}