summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PHPMailer/Manifest2
-rw-r--r--dev-php/PHPMailer/PHPMailer-5.2.16.ebuild (renamed from dev-php/PHPMailer/PHPMailer-5.2.14.ebuild)9
2 files changed, 6 insertions, 5 deletions
diff --git a/dev-php/PHPMailer/Manifest b/dev-php/PHPMailer/Manifest
index 2ea457dcd5bf..505802d649f8 100644
--- a/dev-php/PHPMailer/Manifest
+++ b/dev-php/PHPMailer/Manifest
@@ -1 +1 @@
-DIST PHPMailer-5.2.14.tar.gz 192100 SHA256 54acc99a6cdd807c5646e712e4499308d885bc76a3dc27679388fe0359bd3a93 SHA512 f3cacbdea4b008e6f0bddbc06fc08c8afebe64f74dded5fe87022a6ccf36db19bf4cf4f303399373c250afec32f87645eab6acd8adbcfbed3af349edd51f9e49 WHIRLPOOL c202ad61a6380b23f3e7460f333e396ef9be16f097a798f048a806d184a8ed2f50a32183d7420e7e1439865367177df0d352246928a67b315a89ed339534ad6c
+DIST PHPMailer-5.2.16.tar.gz 195931 SHA256 0700a64ec57caaa710c3e499160099ec21155c6bd937b5bd3ccc910c2d4d2d06 SHA512 5e2503adc58865c10234ccd3ea09d0ae77f687bb4936be732119c922caa8ec35c3646d07dc7d37f121ae09191ee34f434483cc702cfc98cac8429803915a2049 WHIRLPOOL b68830d8467891adbde7db916d4d256cb65dd73bb9eb02938ebd9bac9bda39b64fb6701831b020201fda6f07e0b717074ec3debf4eb139ad9b2636b4a46c9241
diff --git a/dev-php/PHPMailer/PHPMailer-5.2.14.ebuild b/dev-php/PHPMailer/PHPMailer-5.2.16.ebuild
index 880f5b0c1831..fc6e01fb7c7a 100644
--- a/dev-php/PHPMailer/PHPMailer-5.2.14.ebuild
+++ b/dev-php/PHPMailer/PHPMailer-5.2.16.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
DESCRIPTION="Full-featured email creation and transfer class for PHP"
HOMEPAGE="https://github.com/PHPMailer/PHPMailer"
@@ -16,7 +16,7 @@ IUSE="doc +examples test"
RDEPEND="dev-lang/php:*"
DEPEND="${RDEPEND}
doc? ( dev-php/phpDocumentor )
- test? ( dev-php/phpunit )"
+ test? ( ${RDEPEND} dev-php/phpunit )"
# The test suite requires network access.
RESTRICT=test
@@ -25,6 +25,7 @@ src_compile(){
if use doc; then
phpdoc --filename="class.*.php" \
--target="./html" \
+ --cache-folder="${T}" \
--title="${PN}" \
--sourcecode \
--force \
@@ -41,7 +42,7 @@ src_install(){
dodoc docs/*
use examples && dodoc -r examples
- use doc && dohtml -r html/*
+ use doc && dodoc -r html/*
}
src_test(){