summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/PyQt-builder')
-rw-r--r--dev-python/PyQt-builder/Manifest1
-rw-r--r--dev-python/PyQt-builder/PyQt-builder-1.10.3.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/PyQt-builder/Manifest b/dev-python/PyQt-builder/Manifest
index c04be8f9ec1c..d1dec6a85b3b 100644
--- a/dev-python/PyQt-builder/Manifest
+++ b/dev-python/PyQt-builder/Manifest
@@ -1 +1,2 @@
DIST PyQt-builder-1.10.1.tar.gz 5725429 BLAKE2B e7aaa0a3c1eb8aeea0aa5f2d5d7beda1edc46e90c0a21b608d2dffe205a67170daaa6615253706b5f9856a27d66715692ceffe81b9b45eafd4d608df79741d6f SHA512 2e48c1066bb12c1f50700933b0f489158f29f62a1239b570dc053cb042eca9bd4ee83f66b855b0596cfb6dc2e844434c15563abbb3846bf5960d03441f497b83
+DIST PyQt-builder-1.10.3.tar.gz 5725537 BLAKE2B da1abab8fa46da9dee15dedbcf84068b80ce081e87e640fc50642ff6dd15aa3963b9186a32193f3c492c4f141fb7242f13395a539f436575532a5735e3c85720 SHA512 26a01cb2dc4428277cc62da23404433d75f84c61360c35dfd9c440841adbcb1bf39b2211e4e33967ee2730c163dd1585b5fcbd88c6fd7efa2f1f84915a390e2a
diff --git a/dev-python/PyQt-builder/PyQt-builder-1.10.3.ebuild b/dev-python/PyQt-builder/PyQt-builder-1.10.3.ebuild
new file mode 100644
index 000000000000..4d69521c2f08
--- /dev/null
+++ b/dev-python/PyQt-builder/PyQt-builder-1.10.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The PEP 517 compliant PyQt build system"
+HOMEPAGE="https://www.riverbankcomputing.com/software/pyqt-builder/ https://pypi.org/project/PyQt-builder/"
+
+MY_P=${PN}-${PV/_pre/.dev}
+if [[ ${PV} == *_pre* ]]; then
+ SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+fi
+S=${WORKDIR}/${MY_P}
+
+LICENSE="|| ( GPL-2 GPL-3 SIP )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/sip-5.5[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx doc --no-autodoc
+
+python_prepare_all() {
+ # don't install prebuilt Windows DLLs
+ sed -i -e "s:'dlls/\*/\*',::" setup.py || die
+ rm -r "${PN/-/_}.egg-info" || die
+
+ distutils-r1_python_prepare_all
+}