summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/aiocontextvars/aiocontextvars-0.2.2.ebuild')
-rw-r--r--dev-python/aiocontextvars/aiocontextvars-0.2.2.ebuild27
1 files changed, 0 insertions, 27 deletions
diff --git a/dev-python/aiocontextvars/aiocontextvars-0.2.2.ebuild b/dev-python/aiocontextvars/aiocontextvars-0.2.2.ebuild
deleted file mode 100644
index 6555d13515e2..000000000000
--- a/dev-python/aiocontextvars/aiocontextvars-0.2.2.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 2019-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# this is a backport, do not add extra impls
-PYTHON_COMPAT=( python3_6 )
-inherit distutils-r1
-
-DESCRIPTION="Asyncio support for PEP-567 contextvars backport"
-HOMEPAGE="https://github.com/fantix/aiocontextvars"
-SRC_URI="https://github.com/fantix/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 x86"
-
-DEPEND="test? ( dev-python/pytest-asyncio[${PYTHON_USEDEP}] )"
-RDEPEND="dev-python/contextvars[${PYTHON_USEDEP}]"
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest
-
-python_prepare_all() {
- sed -e 's|'\''pytest-runner'\'',\?||' -i setup.py || die
- distutils-r1_python_prepare_all
-}