summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ansible-runner/ansible-runner-2.1.0.ebuild')
-rw-r--r--dev-python/ansible-runner/ansible-runner-2.1.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/ansible-runner/ansible-runner-2.1.0.ebuild b/dev-python/ansible-runner/ansible-runner-2.1.0.ebuild
new file mode 100644
index 000000000000..50bd03e9f739
--- /dev/null
+++ b/dev-python/ansible-runner/ansible-runner-2.1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool and python library that helps when interfacing with Ansible"
+HOMEPAGE="https://github.com/ansible/ansible-runner"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+# TODO: fix broken tests
+RESTRICT+=" test"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/python-daemon[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e '/cov/d' -i pytest.ini || die
+ distutils-r1_python_prepare_all
+}