summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ansicolor')
-rw-r--r--dev-python/ansicolor/Manifest2
-rw-r--r--dev-python/ansicolor/ansicolor-0.3.2-r1.ebuild (renamed from dev-python/ansicolor/ansicolor-0.2.6-r1.ebuild)18
-rw-r--r--dev-python/ansicolor/ansicolor-9999.ebuild16
-rw-r--r--dev-python/ansicolor/metadata.xml11
4 files changed, 30 insertions, 17 deletions
diff --git a/dev-python/ansicolor/Manifest b/dev-python/ansicolor/Manifest
index 01708bb5bf74..fe3b67070d1a 100644
--- a/dev-python/ansicolor/Manifest
+++ b/dev-python/ansicolor/Manifest
@@ -1 +1 @@
-DIST ansicolor-0.2.6.tar.gz 6224 BLAKE2B 38ffd0e9a88c886ebad25c4f0072f2f8f833e028c3bc14eb89252c1c0b501f973c9b3e371b4c605a3b98df33eb7203a963797d3ee56cf87b0afb927b19096fd5 SHA512 44c7dc6f621fc3044d4a52acb96e7e497578e025090633bfc8cbf686d7461da018f64502b477a6090e60747481f320cebaad00ee0776c9f4c52d4abbb1812121
+DIST ansicolor-0.3.2.gh.tar.gz 118221 BLAKE2B f3f621298858974522dd05665c66ffebfc335291b61c6f0e6f835aaddf099559412f12979ad2a43001690b430125c8e1a8fd5427ad3268393d75bd736353d598 SHA512 de1e1bc9d8a02accaa57a64e5d2ea1f510545b3ab83218c47c7a1861e8438862c222147c9dcab0fcb1ec4055dcee07d6cde6d7bfecfbf9ac55c3bb76ac0fb0ab
diff --git a/dev-python/ansicolor/ansicolor-0.2.6-r1.ebuild b/dev-python/ansicolor/ansicolor-0.3.2-r1.ebuild
index 744f7665ed00..5dd87fb09a73 100644
--- a/dev-python/ansicolor/ansicolor-0.2.6-r1.ebuild
+++ b/dev-python/ansicolor/ansicolor-0.3.2-r1.ebuild
@@ -1,21 +1,23 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/numerodix/ansicolor.git"
+else
# pypi tars don't include tests and github repo is missing release tags,
# so only enabling tests for 9999 at this time
- distutils_enable_tests pytest
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="amd64 x86"
+ SRC_URI="
+ https://github.com/numerodix/ansicolor/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+ KEYWORDS="amd64 ~arm64 x86"
fi
DESCRIPTION="Produce ansi color output and colored highlighting and diffing"
@@ -23,3 +25,5 @@ HOMEPAGE="https://github.com/numerodix/ansicolor https://pypi.org/project/ansico
LICENSE="Apache-2.0"
SLOT="0"
+
+distutils_enable_tests pytest
diff --git a/dev-python/ansicolor/ansicolor-9999.ebuild b/dev-python/ansicolor/ansicolor-9999.ebuild
index 25c10321fe62..4d55e8a5e08c 100644
--- a/dev-python/ansicolor/ansicolor-9999.ebuild
+++ b/dev-python/ansicolor/ansicolor-9999.ebuild
@@ -1,20 +1,22 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/numerodix/ansicolor.git"
+else
# pypi tars don't include tests and github repo is missing release tags,
# so only enabling tests for 9999 at this time
- distutils_enable_tests pytest
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ SRC_URI="
+ https://github.com/numerodix/ansicolor/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
@@ -23,3 +25,5 @@ HOMEPAGE="https://github.com/numerodix/ansicolor https://pypi.org/project/ansico
LICENSE="Apache-2.0"
SLOT="0"
+
+distutils_enable_tests pytest
diff --git a/dev-python/ansicolor/metadata.xml b/dev-python/ansicolor/metadata.xml
index 50b2ecb53677..fb93ec31d51a 100644
--- a/dev-python/ansicolor/metadata.xml
+++ b/dev-python/ansicolor/metadata.xml
@@ -1,14 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
+ <maintainer type="person" proxied="yes">
<email>lucianposton@pm.me</email>
<name>Lucian Poston</name>
</maintainer>
- <maintainer type="project">
+ <maintainer type="project" proxied="proxy">
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="github">numerodix/ansicolor</remote-id>
<remote-id type="pypi">ansicolor</remote-id>