summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/anyjson/anyjson-0.3.3-r1.ebuild')
-rw-r--r--dev-python/anyjson/anyjson-0.3.3-r1.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/anyjson/anyjson-0.3.3-r1.ebuild b/dev-python/anyjson/anyjson-0.3.3-r1.ebuild
deleted file mode 100644
index 8c2e5212b1f4..000000000000
--- a/dev-python/anyjson/anyjson-0.3.3-r1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Wraps the best available JSON implementation available in a common interface"
-HOMEPAGE="https://bitbucket.org/runeh/anyjson"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# please keep all supported implementations in 'test?'
-# to make sure the package is used in the widest way
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- cp -r -l tests "${BUILD_DIR}" || die
- if [[ ${EPYTHON} == python3* ]]; then
- 2to3 -w --no-diffs "${BUILD_DIR}"/tests || die
- fi
-
- nosetests -w "${BUILD_DIR}"/tests || die "Tests fail with ${EPYTHON}"
-}