summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/apipkg/apipkg-1.4.ebuild')
-rw-r--r--dev-python/apipkg/apipkg-1.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/apipkg/apipkg-1.4.ebuild b/dev-python/apipkg/apipkg-1.4.ebuild
new file mode 100644
index 000000000000..b3ec9583c0e7
--- /dev/null
+++ b/dev-python/apipkg/apipkg-1.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="namespace control and lazy-import mechanism"
+HOMEPAGE="http://pypi.python.org/pypi/apipkg"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/hgdistver[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test test_apipkg.py || die "Tests fail under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}