summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/appdirs/appdirs-1.4.3.ebuild')
-rw-r--r--dev-python/appdirs/appdirs-1.4.3.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/appdirs/appdirs-1.4.3.ebuild b/dev-python/appdirs/appdirs-1.4.3.ebuild
deleted file mode 100644
index 3af7a9410b80..000000000000
--- a/dev-python/appdirs/appdirs-1.4.3.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Module for determining appropriate platform-specific dirs"
-HOMEPAGE="https://github.com/ActiveState/appdirs"
-SRC_URI="https://github.com/ActiveState/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-PATCHES=( "${FILESDIR}"/${PN}-1.4.3-distutils.patch )
-
-python_test() {
- "${PYTHON}" test/test_api.py || die "Tests fail with ${EPYTHON}"
-}
-
-[[ ${PV} == 1.4.3 ]] || die "Please remove pkg_preinst from the ebuild"
-pkg_preinst() {
- _remove_egg_info() {
- local pyver="$("${PYTHON}" -c 'import sys; print(sys.version[:3])')"
- local egginfo="${ROOT%/}$(python_get_sitedir)/${P}-py${pyver}.egg-info"
- if [[ -d ${egginfo} ]]; then
- einfo "Removing ${egginfo}"
- rm -r "${egginfo}" || die
- fi
- }
- python_foreach_impl _remove_egg_info
-}