summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/argparse-manpage/argparse-manpage-1.4.ebuild')
-rw-r--r--dev-python/argparse-manpage/argparse-manpage-1.4.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/argparse-manpage/argparse-manpage-1.4.ebuild b/dev-python/argparse-manpage/argparse-manpage-1.4.ebuild
new file mode 100644
index 000000000000..ad772920204b
--- /dev/null
+++ b/dev-python/argparse-manpage/argparse-manpage-1.4.ebuild
@@ -0,0 +1,18 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Automatically build man-pages for your Python project"
+HOMEPAGE="https://github.com/praiskup/argparse-manpage https://pypi.org/project/argparse-manpage/"
+SRC_URI="https://github.com/praiskup/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest