summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/awxkit/awxkit-19.2.1.ebuild')
-rw-r--r--dev-python/awxkit/awxkit-19.2.1.ebuild29
1 files changed, 0 insertions, 29 deletions
diff --git a/dev-python/awxkit/awxkit-19.2.1.ebuild b/dev-python/awxkit/awxkit-19.2.1.ebuild
deleted file mode 100644
index 3023714031c0..000000000000
--- a/dev-python/awxkit/awxkit-19.2.1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Command line interface for Ansible AWX"
-HOMEPAGE="https://github.com/ansible/awx"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
- dev-python/websocket-client[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- sed -e 's|websocket-client==[[:digit:]\.]*|websocket-client|' \
- -i setup.py || die
- distutils-r1_python_prepare_all
-}