summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/bashate')
-rw-r--r--dev-python/bashate/Manifest2
-rw-r--r--dev-python/bashate/bashate-0.6.0.ebuild34
-rw-r--r--dev-python/bashate/bashate-2.1.1.ebuild25
-rw-r--r--dev-python/bashate/metadata.xml11
4 files changed, 33 insertions, 39 deletions
diff --git a/dev-python/bashate/Manifest b/dev-python/bashate/Manifest
index d2e9a4bc9cbd..f1e70f2a83fb 100644
--- a/dev-python/bashate/Manifest
+++ b/dev-python/bashate/Manifest
@@ -1 +1 @@
-DIST bashate-0.6.0.tar.gz 30980 BLAKE2B 5b210edaa44a0652a03f30a641a072dba1482e1ca3b42c6b7140a52349ddb271f0137373a4d2f364032c22c176d6caf14be2635038df8a4e86585773d17a1f97 SHA512 bb64d8de0143bf2662497b1571ce654f4ceeb7d1dea3f625705b609ab70ed3b4bca6266c4eba7c2e7d99a1520fb9566a4a4daefa34c9c16538537b446c1da255
+DIST bashate-2.1.1.tar.gz 34875 BLAKE2B 9af27813697be12132f58fa13b4f415ce4991795d3e831e651f24a884438775ecaf938f27120ea0fc990f72d8edc5def8ed4bfbc163ca47fabf10a8e350b0b41 SHA512 093ad491b41b73402d316baba894b5f327f07702641f13ece4beb1578d5dfaccbff1e3e0773a799f1acd84443d5a8606288b7c586d5120bb10adcf4427d6f96c
diff --git a/dev-python/bashate/bashate-0.6.0.ebuild b/dev-python/bashate/bashate-0.6.0.ebuild
deleted file mode 100644
index 41ac6f0d758f..000000000000
--- a/dev-python/bashate/bashate-0.6.0.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-DISTUTILS_IN_SOURCE_BUILD=TRUE
-
-# time
-RESTRICT="test"
-
-inherit distutils-r1
-
-DESCRIPTION="A pep8 equivalent for bash scripts"
-HOMEPAGE="https://pypi.org/project/bashate/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0
-"
-RDEPEND="
- >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
- !~dev-python/Babel-2.4.0
-"
-
-python_install_all() {
- distutils-r1_python_install_all
-}
diff --git a/dev-python/bashate/bashate-2.1.1.ebuild b/dev-python/bashate/bashate-2.1.1.ebuild
new file mode 100644
index 000000000000..f5ee7051717c
--- /dev/null
+++ b/dev-python/bashate/bashate-2.1.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pep8 equivalent for bash scripts"
+HOMEPAGE="https://pypi.org/project/bashate/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 arm64 x86"
+
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
diff --git a/dev-python/bashate/metadata.xml b/dev-python/bashate/metadata.xml
index c25cf671b7a9..7c91ab840b47 100644
--- a/dev-python/bashate/metadata.xml
+++ b/dev-python/bashate/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>prometheanfire@gentoo.org</email>
@@ -9,10 +9,13 @@
<email>openstack@gentoo.org</email>
<name>Openstack</name>
</maintainer>
- <longdescription lang="en">
- A pep8 equivalent for bash scripts
- </longdescription>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">bashate</remote-id>
+ <remote-id type="github">openstack/bashate</remote-id>
</upstream>
</pkgmetadata>