summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/batinfo/batinfo-0.4.2.ebuild')
-rw-r--r--dev-python/batinfo/batinfo-0.4.2.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/batinfo/batinfo-0.4.2.ebuild b/dev-python/batinfo/batinfo-0.4.2.ebuild
new file mode 100644
index 000000000000..28cd559c9ba2
--- /dev/null
+++ b/dev-python/batinfo/batinfo-0.4.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple Python lib to retreive battery information"
+HOMEPAGE="https://github.com/nicolargo/batinfo https://pypi.org/project/batinfo/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=""
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"