summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/bibtexparser')
-rw-r--r--dev-python/bibtexparser/bibtexparser-1.1.0.ebuild14
1 files changed, 3 insertions, 11 deletions
diff --git a/dev-python/bibtexparser/bibtexparser-1.1.0.ebuild b/dev-python/bibtexparser/bibtexparser-1.1.0.ebuild
index 5b5c3522fdae..a72537c27481 100644
--- a/dev-python/bibtexparser/bibtexparser-1.1.0.ebuild
+++ b/dev-python/bibtexparser/bibtexparser-1.1.0.ebuild
@@ -3,27 +3,19 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1 python-r1
DESCRIPTION="A BibTeX parser written in python"
HOMEPAGE="https://github.com/sciunto-org/python-bibtexparser"
SRC_URI="https://github.com/sciunto-org/python-bibtexparser/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/python-${P}"
LICENSE="|| ( BSD LGPL-3 )"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/python-${P}"
-src_test() {
- python_foreach_impl nosetests
-}
+distutils_enable_tests nose