summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/boto')
-rw-r--r--dev-python/boto/Manifest1
-rw-r--r--dev-python/boto/boto-2.42.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto/Manifest b/dev-python/boto/Manifest
index 1ec41fd1ae6c..ec39e367b88e 100644
--- a/dev-python/boto/Manifest
+++ b/dev-python/boto/Manifest
@@ -6,3 +6,4 @@ DIST boto-2.38.0.tar.gz 1423863 SHA256 d9083f91e21df850c813b38358dc83df16d7f2531
DIST boto-2.39.0.tar.gz 1434775 SHA256 950c5bf36691df916b94ebc5679fed07f642030d39132454ec178800d5b6c58a SHA512 58afdbde3818d84b25ad330c8d417dd2400c4be40d99d7895eda94b99f9a1d86e164894c05faee71b4433ea33866be1e3fea3046b08f98577a2cd60e9dab3f3d WHIRLPOOL ea80c168ee45febe8a37a96bd8fba8eafb2b68d695e369c3f4c3974c9909d67b9f255dab5e70a6ae9bdbcae7b0ffc89f6e6b2277933571e299d2ada0d7cc773b
DIST boto-2.40.0.tar.gz 1439746 SHA256 e12d5fca11fcabfd0acd18f78651e0f0dba60f958a0520ff4e9b73e35cd9928f SHA512 a4a2d5659a70a70c77f4713db2bb63e1c975f21746575ededd56a7220899d7dd8f4bf4d5cfe72be6a3045dc5a9e1152962c4650b09fa10703ec98bd23392d4cf WHIRLPOOL cb223e0b29c25e7190655a18402983f4c48ef0a1cfc759756a092de05470b72246afddab2ca5c7382efd7d922c029b46d8cf45c48510f3950cbd624b711fa759
DIST boto-2.41.0.tar.gz 1440323 SHA256 c638acdecb0a2383b517c15ac2a6ccf15a2f806aee923cc4448a59b9b73b52e0 SHA512 ffb503e8f7ec84ec973e109ae9524e1db2ef5f34d9424c380eed9a85871f07f8c9c798ca358fefd772ff45a72226bb02eebbbf6ab2d56b2442c41ede736f6f5e WHIRLPOOL b87f8af16224187b1b9fd294491f2bd1b9222d32e1718fdedeb5d3efb6cc89f24de9984481597cb6317d90ff70a2f984ddb67f57b86fad8c7eb1410f9e41b70d
+DIST boto-2.42.0.tar.gz 1442326 SHA256 dcf140d4ce535bb8f5266d1750c16def4d50f6c46eff27fab38b55d0d74d5ac7 SHA512 5f45d56ef0d5b64f1f585f4d144cafd1bd2b05f1b0ec02748c27057f91ed9d94228ea2c24f4f081d4424285eecd1b749ca65952e769c4e94db0b944d79670076 WHIRLPOOL e81a77d5c4891eec1ce980fdf599433cc6866e3aaccf1eaf59e13843559dd29c9bcd6c83090361f1e89698e9a6f8d33fe0da71dd816bf318dc54860ac6e60252
diff --git a/dev-python/boto/boto-2.42.0.ebuild b/dev-python/boto/boto-2.42.0.ebuild
new file mode 100644
index 000000000000..532f9359b21a
--- /dev/null
+++ b/dev-python/boto/boto-2.42.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Amazon Web Services API"
+HOMEPAGE="https://github.com/boto/boto https://pypi.python.org/pypi/boto"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc test"
+
+REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+# requires Amazon Web Services keys to pass some tests
+RESTRICT="test"
+
+pkg_setup() {
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
+}
+
+python_test() {
+ "${PYTHON}" tests/test.py -v || die "Tests fail with ${EPYTHON}"
+}
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/source/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ # Appease the doc build and supply a file for _static
+ # the usual emake -C docs doesn't work under this authorship
+ cd docs && mkdir source/_static || die
+ emake html
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}