summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/bpython/bpython-0.22.1.ebuild')
-rw-r--r--dev-python/bpython/bpython-0.22.1.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/bpython/bpython-0.22.1.ebuild b/dev-python/bpython/bpython-0.22.1.ebuild
deleted file mode 100644
index 53cc9af10082..000000000000
--- a/dev-python/bpython/bpython-0.22.1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Syntax highlighting and autocompletion for the Python interpreter"
-HOMEPAGE="https://www.bpython-interpreter.org/ https://github.com/bpython/bpython https://pypi.org/project/bpython/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="clipboard +jedi urwid watch"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=dev-python/curtsies-0.3.5[${PYTHON_USEDEP}]
- dev-python/cwcwidth[${PYTHON_USEDEP}]
- dev-python/greenlet[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/pyxdg[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- clipboard? ( dev-python/pyperclip[${PYTHON_USEDEP}] )
- jedi? ( dev-python/jedi[${PYTHON_USEDEP}] )
- urwid? ( dev-python/urwid[${PYTHON_USEDEP}] )
- watch? ( dev-python/watchdog[${PYTHON_USEDEP}] )
- "
-# sphinx is used implicitly to build manpages
-BDEPEND="
- dev-python/sphinx[${PYTHON_USEDEP}]
- "
-
-DOCS=( AUTHORS.rst CHANGELOG.rst )
-
-distutils_enable_sphinx doc/sphinx/source --no-autodoc
-distutils_enable_tests unittest