summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/calver/calver-2021.7.30.ebuild')
-rw-r--r--dev-python/calver/calver-2021.7.30.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/calver/calver-2021.7.30.ebuild b/dev-python/calver/calver-2021.7.30.ebuild
deleted file mode 100644
index ee5748e2277a..000000000000
--- a/dev-python/calver/calver-2021.7.30.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Setuptools extension for CalVer package versions"
-HOMEPAGE="
- https://github.com/di/calver/
- https://pypi.org/project/calver/
-"
-SRC_URI="
- https://github.com/di/calver/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-BDEPEND="
- test? (
- dev-python/pretend[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- distutils-r1_src_prepare
-
- # bootstrap workaround, until https://github.com/di/calver/pull/8
- # is merged
- cat > setup.cfg <<-EOF
- [metadata]
- version = ${PV}
- EOF
-}