summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cheetah3')
-rw-r--r--dev-python/cheetah3/Manifest2
-rw-r--r--dev-python/cheetah3/cheetah3-3.2.6.ebuild41
-rw-r--r--dev-python/cheetah3/cheetah3-3.3.1.ebuild44
-rw-r--r--dev-python/cheetah3/metadata.xml3
4 files changed, 47 insertions, 43 deletions
diff --git a/dev-python/cheetah3/Manifest b/dev-python/cheetah3/Manifest
index d2a51d68201b..f92c41d0b7ab 100644
--- a/dev-python/cheetah3/Manifest
+++ b/dev-python/cheetah3/Manifest
@@ -1 +1 @@
-DIST cheetah3-3.2.6.tar.gz 2481158 BLAKE2B cb8ad192ae9caf0d1284294b323cf4a918cd2fc951bae25867d69a3dd7933728056b76fbf52a22d34f290056a96cce7d9ccbeb2404f2f0bb782f8db8b7453e47 SHA512 abf74def695018a79cb1364f60e402e7e0095a4d2f069decfbddf42501d865b70451ebc7b52abc67aa23e57276d7a3b8c2894a9571876e15db43cd1358f74d31
+DIST cheetah3-3.3.1.gh.tar.gz 315007 BLAKE2B 627cb435db1cf274861a29b993f49457c1ba4147b6e1514b5d5961a2fd565c39ff9cae3bcd9665379c5206dc2cef98a6bf159781e664d75d87fa8c4244ec4e43 SHA512 057d3772390076157a0e09e6b5e60ad0ec3b1669aa62741bcfd314f846bba091884d361382d6399e73bce06aaf49366ee3cbeb040c6f5b3e00423eefd440c300
diff --git a/dev-python/cheetah3/cheetah3-3.2.6.ebuild b/dev-python/cheetah3/cheetah3-3.2.6.ebuild
deleted file mode 100644
index 750ee0a37321..000000000000
--- a/dev-python/cheetah3/cheetah3-3.2.6.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{8..9} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
-inherit distutils-r1
-
-DESCRIPTION="Python-powered template engine and code generator"
-HOMEPAGE="https://cheetahtemplate.org/ https://pypi.org/project/Cheetah3/"
-SRC_URI="https://github.com/CheetahTemplate3/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv x86"
-SLOT="0"
-
-RDEPEND="
- dev-python/markdown[${PYTHON_USEDEP}]
- !dev-python/cheetah
-"
-BDEPEND="${RDEPEND}"
-
-DOCS=( ANNOUNCE.rst README.rst TODO )
-
-python_prepare_all() {
- # Disable broken tests.
- sed \
- -e "/Unicode/d" \
- -e "s/if not sys.platform.startswith('java'):/if False:/" \
- -e "/results =/a\\ sys.exit(not results.wasSuccessful())" \
- -i Cheetah/Tests/Test.py || die "sed failed"
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- cp -r "${S}/Cheetah/Tests/ImportHooksTemplates" \
- "${BUILD_DIR}/lib/Cheetah/Tests/ImportHooksTemplates" || die
-
- "${EPYTHON}" Cheetah/Tests/Test.py || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/cheetah3/cheetah3-3.3.1.ebuild b/dev-python/cheetah3/cheetah3-3.3.1.ebuild
new file mode 100644
index 000000000000..2fb8748e3d85
--- /dev/null
+++ b/dev-python/cheetah3/cheetah3-3.3.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="Python-powered template engine and code generator"
+HOMEPAGE="
+ https://cheetahtemplate.org/
+ https://github.com/CheetahTemplate3/Cheetah3/
+ https://pypi.org/project/Cheetah3/
+"
+SRC_URI="
+ https://github.com/CheetahTemplate3/Cheetah3/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+KEYWORDS="amd64 arm arm64 ~loong ~ppc64 ~riscv x86"
+SLOT="0"
+
+RDEPEND="
+ dev-python/markdown[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+DOCS=( ANNOUNCE.rst README.rst TODO )
+
+python_test() {
+ # the package can't handle TMPDIR with hyphens
+ # https://github.com/CheetahTemplate3/cheetah3/issues/53
+ local -x TMPDIR=/tmp
+
+ "${EPYTHON}" Cheetah/Tests/Test.py || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/cheetah3/metadata.xml b/dev-python/cheetah3/metadata.xml
index 52f8ccc1f81d..2e25efbd05cf 100644
--- a/dev-python/cheetah3/metadata.xml
+++ b/dev-python/cheetah3/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>python@gentoo.org</email>
@@ -11,5 +11,6 @@ are its principle user group, but it has many potential uses and is also being
used to generate C++ game code, Java, SQL, form emails, and even Python code.</longdescription>
<upstream>
<remote-id type="pypi">Cheetah3</remote-id>
+ <remote-id type="github">CheetahTemplate3/cheetah3</remote-id>
</upstream>
</pkgmetadata>