summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/click/click-7.0-r1.ebuild')
-rw-r--r--dev-python/click/click-7.0-r1.ebuild29
1 files changed, 0 insertions, 29 deletions
diff --git a/dev-python/click/click-7.0-r1.ebuild b/dev-python/click/click-7.0-r1.ebuild
deleted file mode 100644
index 170da4c3b751..000000000000
--- a/dev-python/click/click-7.0-r1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A Python package for creating beautiful command line interfaces"
-SRC_URI="https://github.com/pallets/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-HOMEPAGE="https://palletsprojects.com/p/click/ https://pypi.org/project/click/"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~s390 sparc x86"
-IUSE="examples"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-distutils_enable_sphinx docs \
- '>=dev-python/docutils-0.14' \
- dev-python/pallets-sphinx-themes
-distutils_enable_tests pytest
-
-python_install_all() {
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}