summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cliff/cliff-2.18.0.ebuild')
-rw-r--r--dev-python/cliff/cliff-2.18.0.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/dev-python/cliff/cliff-2.18.0.ebuild b/dev-python/cliff/cliff-2.18.0.ebuild
deleted file mode 100644
index 6087508896d4..000000000000
--- a/dev-python/cliff/cliff-2.18.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-# entry_points is added via [entry_points] in setup.cfg
-_DISTUTILS_SETUPTOOLS_WARNED=1
-
-VIRTUALX_REQUIRED="test"
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Command Line Interface Formulation Framework"
-HOMEPAGE="https://github.com/openstack/cliff"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~hppa ~mips ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0"
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
- >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
- >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
- >=dev-python/stestr-2.1.0[${PYTHON_USEDEP}]
- )
-"
-# source files stipulate <sphinx-1.3 however build effected perfectly with sphinx-1.3.1
-RDEPEND="
- ${CDEPEND}
- >=dev-python/cmd2-0.8.0[${PYTHON_USEDEP}]
- >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
- <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
- >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
- >=dev-python/unicodecsv-0.8.0[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
-"
-
-python_test() {
- stestr init || die "stestr init failed under ${EPYTHON}"
- # needs outside access, so blacklist the test
- virtx stestr run --black-regex cliff.tests.test_app.TestIO.test_writer_encoding
-}