summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/clikit/clikit-0.6.2.ebuild')
-rw-r--r--dev-python/clikit/clikit-0.6.2.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/dev-python/clikit/clikit-0.6.2.ebuild b/dev-python/clikit/clikit-0.6.2.ebuild
index 8bb676a6f1ba..200eb8b1216e 100644
--- a/dev-python/clikit/clikit-0.6.2.ebuild
+++ b/dev-python/clikit/clikit-0.6.2.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=pyproject.toml
-PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Group of utilities to build beautiful and testable command line interfaces"
@@ -27,9 +27,11 @@ BDEPEND="
distutils_enable_tests pytest
-python_prepare_all() {
- # skip failing test
- rm tests/utils/test_terminal.py || die
-
- distutils-r1_python_prepare_all
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local EPYTEST_DESELECT=(
+ # skip failing test
+ tests/utils/test_terminal.py
+ )
+ epytest
}